Cannot see any devices on my network when browsing to add files

Hi, I’m very new to OSMC. I installed OSMC on a Raspberry Pi 2 today. It’s hooked up to my home network (wired) and I have already installed the BBC iPlayer add-on which works great.

However, when I go to add video files and try to browse my network for DLNA servers, I can’t see any devices. I have Serviio set up on a PC on the network that every other device on the network can see, except the OSMC.

The network options I see when trying to browse are:

HDHomerun Devices
Network File System
SAP Streams

Any tips would be appreciated :smile:

You should have more than that - Home folder and Root filesystem at least.
I also see UPNP devices, Video playlists, Windows network (SMB) and Zeroconf browser.
For some of these you may need to set ‘Expert’ under Settings|sevices’ or settings|system

Sorry Derek, I do also have Home Folder and Root filesystem in the Browse menu - but I only listed the network options because I felt that was pertinent to what I was trying to do.

However, I don’t see UPNP devices, Video playlists, Windows network (SMB) and Zeroconf browser.

I see some of these in Settings>Services in Expert mode. Here I see;
Web server
Remote Control
SMB Client

In UPnP/DLNA I have enabled “Look for remote UPnP players”

Any further help much appreciated :smile:


I’ve given up on this and installed openelec, which worked immediately.

If you still cannot see upnp/dlna server when you browse, then there is probably something wrong in your network setup. A favourite for this is network blocking by router. I can see my serviio server from many devices, but have never remarked it when adding sources for OSMC - but that would be because I mainly use SMB. I have no idea whether logs could help in this case.

Thanks for your suggestion Derek, but I don’t see how it can be the firewall on my router, because I reformatted the SD card and installed OpenElec and it worked immediately. OpenElec can see and access Serviio on a PC on the network. Same RPi device, same network cable, same IP address.

I had tried the three most recent builds of OSMC and none of them could see Serviio, or indeed anything else on the network. But it could access the internet and Serviio could see OSMC.

So I can only conclude the problem lies with OSMC. A great shame, but I have spent hours going through every setting and I wasn’t getting anywhere.

Since my last post I have checked that I can see my serviio server, can add it as source, and can access the files.
Given that, I don’t see how you can blame OSMC per se - but there can still be a problem with your configuration.
Since OpenElec works, then we are looking (probably) for something in the software on your RPi.
Have you checked out CIFS/SMB ?

Without debug enabled log files demonstrating the issue, little can be done to determine why you seem to be the only person with this issue related to upnp.

Derek, I installed OSMC on my RPi straight out of the box. I thought OSMC included the OS. Or is there other software installed on an RPI? (other than some sort of bootstrap)

ActionA - Sorry I was unaware of the need for (or existence of) debug enabled log files. Had I known I would have enabled this.

Rufus, OSMC has the base OS and Kodi as one parcel.
I concur that we cannot do anything more without log file(s).