Cannot start deluge-web on OSMC RC


I am running OSMC RC on a raspberry pi. I installed deluged and deluge-web via apt but I cannot start deluge-web. When I execute the program the ssh interface just freezes and I am not able to do anything. I cannot run the autostart script either because it uses deluge webUI. Is this a known issue on OSMC?

Have you checked that deluge is not trying to start it’s web interface on the same port as Kodi’s web interface ? I think the default for Kodi in the OSMC RC is port 8080.

1 Like

Whenever I type deluge-web into the CLI, it freezes.

By default deluge-web starts in the foreground, that’s why it actually appears as “freezing”. It is in fact working, you can test it. If you press Ctrl+C the process ends.

Quote from here:

“To run it in the background as a daemon, use --fork option. You may also want to set it up as a service.”

Thank you very much!!
I read the wiki page but i missed that line! Now it works. I was trying deluge on the raspberry for the first time and I wasn’t sure of how it worked.
Again, thank you.

Hi again, I have another question. I’m trying to make deluged and deluge-web autostart on OSMC following this guide: UserGuide/Service/DebianUbuntuInitd – Deluge . It seems like it works, based on the comments, but I can’t make the script work. What could it be? Even if I start the script manually via ssh, deluged and deluge-web won’t start.


osmc doesn’t use init.d (or at least that’s what I understood), but systemd. You need to google how to set it up as a service and then it will work. I haven’t done yet since I actually don’t want deluge to start automatically.