Cannot use certain keys in SSH (Pi2)

Pi2, updated with newest updates, using an RC6 remote.

When I SSH in, the password (osmc) works fine, however once into the shell (I assume bash, cannot check), the letters c and s do not respond. Using Putty on windows to ssh into my pi2 with OSMC.

This has apparently been going on for a little while now.

Is this a known issue, has anyone else had this?

About to wipe and redo the Micro SD if I can’t get an answer - wanted to use the pi to run a background script with cron, but cannot for obviously reasons (no sudo, no cron, no nothing).

Also could not get into the internal shell using a keyboard locally either (attached a wireless RF keyboard for this purpose when I discovered SSH was not working, and cannot get into the shell at all).

Nope, nobody has ever reported this before and I can’t for the life of me think of a reason how it might happen either.

There are several methods to log into a local console in OSMC - which were you trying to do.

And if by “wireless RF” keyboard you mean a Bluetooth keyboard, that would not work during early boot as many services have to be running for a bluetooth keyboard to work.

The wireless RF uses a dongle that transmits RF to the keyboard and mouse.

And I tried to get into local console by finding anything in the menus, couldn’t.

Just looked up how to - did the escape thing during the splash and I got in.

Username and password of osmc worked fine - but then s and c still not working.

Start over time.

Is this a QWERTY keyboard?

https://osmc.tv/wiki/general/accessing-the-command-line/

Yes it is a qwerty keyboard in both instances.

Also of note - the RF keyboard was unplugged during several of my attempts to use the SSH and I’ve done power offs, reboots, etc to try resetting the raspi and each time same thing.

Try a normal wired USB keyboard.

Just tried that, same thing.

I don’t think it’s the keyboard, as I said I’ve had the RF keyboard unplugged most of the time I just use an RC6 remote receiver.

Actually, just thought of something, going to leave the RC6 unplugged and see if that changes anything. Back in a tick.

Nevermind, also not it. :frowning:

Rebooted, powered off, powered on with no USB devices plugged in, SSH to OSMC Pi2, same thing, no c no s keys. VERY STRANGE.

What locale do you have set in system? Are these all QWERTY keyboards?

If you can’t type, I assume copy and paste into a “putty” similarly fails to paste ‘s’ or ‘c’ characters?

You’re obviously a bit limited with what you can use as commands without those two keys, but let’s see whether there’s something you can try please:

putty in to a shell (or interrupt boot and log in on the console, or …). Then:

ln /bin/*tty /tmp/x
/tmp/x -a

I’m wondering whether somehow (and I won’t even try to guess how …) your stty (what special character does what) settings have become … confused. If you execute those 2 commands (carefully selected so as not to require ‘s’ or ‘c’ characters :slight_smile:), you should see something like this:

osmc@Arthur:~$ ln /bin/*tty /tmp/x
osmc@Arthur:~$ /tmp/x -a
speed 38400 baud; rows 84; columns 160; line = 0;
intr = ^C; quit = ^; erase = ^H; kill = ^X; eof = ^D; eol = ; eol2 = ; swtch = ; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ; flush = ^O; min = 1; time = 0;
-parenb -parodd -cmspar cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk -brkint ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl -ixon -ixoff -iuclc ixany imaxbel -iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke
osmc@Arthur:~$

Of particular interest is what’s in the “intr = ^C; quit = ^\; erase = ^H; kill = ^X; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = <undef>; flush = ^O;” section …

It’s very unlikely to be this, but it is possible.

Did you login with the username and password ‘osmc’?

They both have ‘s’ and ‘c’ in them.

Output of the x -a:

speed 38400 baud; rows 24; columns 80; line = 0;
intr = ^C; quit = ^; erase = ^?; kill = ^U; eof = ^D; eol = ;
eol2 = ; swtch = ; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R;
werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd -cmspar cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff
-iuclc -ixany -imaxbel -iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt
echoctl echoke

Locale is I believe US, all qwerty keyboards. I don’t have access to non, though I think one could find dvorak it’s not something I’m interested in.

I login with osmc username and password - both in the SSH and when in the local console. It’s not a keyboard specific thing, it seems to be a shell specific thing.

To be clear - the behavior starts when shell loads.

Logging in, s and c show up. When in shell, s and c don’t echo don’t respond.

Yes, which sounds exactly like a stty problem (I was hoping, though really not expecting, to see something like “... intr = C; ... stop = S; ...”).
Unfortunately it obviously isn’t (it was a very long shot) - your stty output looks perfectly normal :frowning:

Yeah.

I’m pretty much expecting I have to wipe and redo.

Locale is USA(12h).

No clue, really.

What device are you SSH’ing in from?

I try and grab the locale from the remote device and generate it locally for the session. Some clients don’t tell me the locale.

See

Sam

I got locale from the OSMC appearance settings.

I’m not sure how I could get this script running on my pi - any c or s characters won’t run.