Cannot use dvd, even with codecs

Is there a perfect world where any of this works? I’m not a programmer, so bear with me, just an extremely frustrated guy trying to make a portable media player for his camper trailer. My goal is to play dvd’s from a usb blu-ray/dvd drive. I’ve tried both OSMC and open elec, neither are responsive. I bought and installed both codecs from Pi, still nothing. I see “play disc” show up, and “eject/load” occasionally works. I’ve seen instructions to put into the code via ssh. I cannot get ssh access through my mac, always fails at the password “raspberry” . Is there a particular brand of dvd drive I’m supposed to use? Is there a magic dance I forgot to perform? Please, is there an instruction manual that shows how to do this? The one with noobs assumes that stuff works, and it just does not-been at it for a couple of weeks. I just want to play dvd movies that I legally own-no copied or ripped files, just dvd. thanks

OSMC Kodi 16.1RC3 on a Pi3

Well assuming that you have installed OSMC which is the forum you are on then the default password is “osmc”.
Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Provide debug logs so that we can understand whats going on
Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

thanks, I’ll give that a try. Still not clear about the logs. I’ve seen the wiki, but it assumes a level of knowledge I don’t have. I’ll reread it.