Cannot use I2S soundcard on Raspberry Pi 2


I’m unable to add my I2S soundcard in OSMC. Steps I’ve taken, are:

  1. Connected the right pins from my DAC to my Raspberry Pi 2 using these instructions:
  2. Installed the RC on my SD Card using the installer.
  3. After booting OSMC on my rapsberry pi 2, performed a software update via My OSMC->Updates
  4. After reboot, selected iqaudio-dac-overlay (or hfberry-dac-overlay) via My OSMC->Pi Config->Hardware Support->soundcard_dac
  5. After reboot, went to Settings->System->Audio output->Audio output device.
    Problem is that I only see HDMI or analog audio.

Am I missing something?

Kind regards,


Are you sure that the DAC version that you have can work on RPi2?
For example - have you had it working using a “regular” Raspbian image from RPF?

Thanks for the tip. I’ll try to get I2S Audio working with the regular raspbian image. Get back to you…

@umberto73 stupid question mate are you clicking ok after you’ve selected the dac that you have I had same problem but all it needed was a couple or reboots and then I could select dac in settings hope this helps

I’m sure I did this (pressing ok). I haven’t tried a couple of reboots.

Just an update: when I use Volumio distribution, my DAC works perfectly. So now I now I have the hardware right.

I’ll try again with OSMC…

Just to let you know; I installed the latest OSMC and it work perfectly!

I’m now one happy OSMC user!