Can't access any repositories (no other network/internet issues)


I have the latest version of OSMC running on a Pi2. I don’t seem to be able to connect to any repositories, or access a zip file at a internet location (I am trying to install some add-ons).

I guess I have tried 2 things. First, if I try to add an add-on of any kind, I get an error when choosing the Kodi official source.

Second, if I add (through file manager) the location of a directory, then I also get a failure to connect.

Pinging google works fine; my internet connection in general is fine.

I can recreate this on a fresh install of the October 2015 version.

Logs are at

I have seen some discussion of DNS settings but I am pretty sure I have never changed mine on OSMC (plus I can recreate this on a fresh install of the October 2015 version).
thanks a lot

My Pi is using as its DNS server, which is the IP address of my router. My router is set to use the ISPs default.


…and it looks like changing the DNS servers on the Pi2 to have solved this problem.

But how frustrating that the default settings didn’t work.


From the logs you appear to have Tethering enabled and the tethering interface has configured itself to be - if you have the same subnet on two different interfaces this will cause problems, and it would certainly prevent your Pi connecting to your router on for dns queries, because the tethering interface on the Pi also has the same IP address.

Does it work if you disable Tethering ?

I was under the impression that connman should automatically choose a different subnet for the tethering interface if it would clash with your network, but it doesn’t seem to have done that.

cc @sam_nazarko

Tethering is not enabled by default. :wink: