Can't access samba shares - file exists error

#1

Hello - just received the vero 4k+ yesterday and am having problems getting it setup.
I can’t access the samba shares (samba server is on a raspberry pi 3 right now).

I’ve tried to transfer settings over to the vero 4k+ by backing up one of the raspberry pi 3 clients settings and adding that to the vero 4k, but that leaves me with still no access to the samba shares. When I try to manually add samba shares, I get “file exists” error.

Smbclient on the 4k lists all of the shared drives as they should be. Can ping the server from the 4k. When I edit the sources.xml file on the 4k to something like: smb://username:password@192.168.0.15:445/share, I can access the shared files in “files” menu, but not in “movies” menu (tells me it is no longer in the library). Changing to SMB protocol 1 and 2 still provides the same problem.

Any idea what’s going on here? I’ve posted logs here https://paste.osmc.tv/vigufeqoko.vhdl

Thanks.

#2

continued working on it. passwords.xml didn’t transfer over. when i transferred it over and restarted, everything seems fine now.

1 Like
#3

In sources.xml you only need “smb://192.168.0.15/share” as the authentication is coming from the passwords.xml. The port number is not needed in either file.

#4

Thanks darwindesign. the problem was that i originally didn’t have the passwords.xml file transferred over with the other settings. without that file, the smb://username:password@192.168.0.15:445/share helped out, but only slightly. Once I realized my issue, the username:password was no longer needed and it worked. your post provides some good insight as to what was happening.