Can't change screenshot folder if current location no longer exists

#1

I recently had a major change to my network environment and I noticed on rebuilding that OSMC is extremely fragile in its boot sequence if the database or sources can’t be found, with no helpful timeout messages. I’ve now encountered a new problem that seems to be related.

I just tried to change the folder location for screenshots, which currently has an nfs path to a network location that no longer exists. Guess what happens when I select the menu item to change the location? Kodi just hangs, doing nothing useful. On a Vero it seemed to eventually timeout, on a Pi it seems to have crashed.

I guess it is trying to get to the location that does not exist, by why on earth would it be set up that way? Is there a workaround I can use in the meantime?

#2

An age later, the Pi has figured out the location isn’t there - an unusable system while waiting for that. Ho hum.

Is there a faster way for me to manage this on my Vero’s ?

#3

The Kodi wiki is quite useful.
https://kodi.wiki/view/Settings/System/Logging#Screenshot_folder

#4

Thanks, but that does not address the issue I was raising, that if a directory is already specified, but not available, then attempting to change it results in a loooong delay, eventually a dialogue comes up but the timeout period is quite extreme. Feel it ought to be a bit smarter.

#5

You will need to manually edit ~/.kodi/userdata/guisettings.xml. This is the line to look for:

<setting id="debug.screenshotpath" default="true"></setting>

Yours will look different than that, so either change it to the path that you want, or to the above to go back to the default.

Stop Kodi before editing the file, and upon restart you should be OK.

#6

Brilliant, thanks very much, worked perfectly.

#7

This behavior is completely dependent on Kodi, not osmc. It should be raised with them if it needs to be changed.

#8

Resetting the menu settings in Settings->System->Logging will also do the trick without having to ssh login to the system:

#9

Thanks, should have spotted that. Was too annoyed by the lack of a sensible timeout on the file location hanging to step back and look at all the options.

1 Like