Can't connect to My Videos files error Connection timed out

I keep getting an error message ‘Connection timed out’, followed by ‘Can’t connect to network’ when I try to access My Videos. Rasberry Pi 2 B+, OSMC, connected to PC via lan cable. I’ve tried rebooting the Raspberry and the router but nothing works. Any ideas please

how did you add the network source?
Don’t add by network name but by ip.

Any logs please

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Appologies, I’m new at this. More detail. When we set everything up it worked perfectly but now it won’t. As I said when I click on PC an Error window pops up saying ‘Connection timed out’. I close it (click on OK) and another window pops up ‘Unable to connect to network’. However I can connect to the internet, so it’s just not seeing the PC. Hope this makes it clearer.

Makes clear your problem, but didn’t bring us closer to a solution without log files