Can't Get Past Setup with USB Periferals


#1

Hi, I have a Raspberry Pi Zero WH, which I have decided to use as a DIY home media centre device. After flashing the latest OSMC image to an SD card with Etcher, I inserted it into the Pi, which I then connected up to my TV. I then connected a power cable and a Logitech K120 keyboard via an adapter chain, then waited for OSMC to install. Once I was prompted to choose my language, I pressed the down arrow on the keyboard only to notice that it wasn’t recieving any power. At first, I thought it was because my Pi didn’t have enough voltage to give to power the USB port, so I connected a Microsoft USB mouse for good measure and it lit up, but oddly did nothing, so I plugged the Pi’s power cable into my iPad charger and tried again, but still got no response. I then tried reflashing, to the same outcome. Any ideas?

This is just for setup, so even a way to enable some kind of app-remote via USB to my computer would be nice, because I can then just connect it to the wireless network and use a remote app.


#2

How are you powering this Pi?
How are the USB peripherals connected?


#3

I have now tried multiple ways of powering the Pi, including directly from the USB port on my TV, an iPad charger, and a powered USB hub. As I do not have any periferals that interface using micro USB, I used a male micro USB to male USB type A, chained to a female-to-female type A which is what I plugged my USB type A Logitech K120 keyboard into. It’s a bit of a mess, I’ll admit. I also tried using the powered hub for the periferals.


#4

None of these are really acceptable ways of powering your device.


#5

How would you suggest that I do it? The powered USB hub is supposed to be able to deliver at least 5 volts and the iPad charger the same.

Edit: I just checked that my 12 watt iPad charger is rated for 5.2 volts at 2.4 amps. If I’m not mistaken that should be sufficient to supply enough power to the Pi to enable powering of periferals.


#6

That’s still a charger that is not designed to ensure to give a stable voltage.
Suggest to get a real Pi Power supply. Check the details below.
Before that you might want to try a different USB power cable.
Lastely if your problem is just your keyboard during setup why not use the TV remote via CEC to finish the setup?

Your power supply probably isn’t up to scratch. You can learn more on our Wiki here: https://osmc.tv/wiki/raspberry-pi/frequently-asked-questions/


#7

While so have not yet been able to successfully connect a keyboard or other USB periferal for use, I was able to successfully use CEC to complete setup. I will order a more adequate power supply soon and see if the issue will be resolved.


#8

I used a male micro USB to male USB type A, chained to a female-to-female type A which is what I plugged my USB type A Logitech K120 keyboard into.

There could be a possibility that the usb cable with type A also isn’t improving your situation. As far as I know the Pi has USB Host/OTG ports. The device connected to the “A” end of the cable at start-up, aka “A-device”, acts as the default host. 2x host without a slave… I’m not sure what happens daisy chained with a bunch of cables :face_with_raised_eyebrow:

I you see a chance to buy a nice short USB OTG cable it certainly wont hurt you in the future.