Can't get Remotepi Board to work

Hello everybody,

I tried to get the remotepi board from msl digital to work with osmc on my RPI 3 but I can’t get it to work with my harmony 650.

I have no problem with libreelec/openelec but I would prefer to keep on using osmc.

On the msl digital website there is some information about libreelec/openelec/rasplex:

Edit the file config.txt located in the root of the SD card and add the following line at the end of the file (if it is not already there), then save the file. Note : You cannot use Windows Notepad to edit the file as it uses Linux convention for new line characters, it will show without linefeeds under Windows Notepad. You can use Notepad++ or another Linux-compatible text editor.

Put the SD card back into the Raspberry Pi and boot
CEC HAS TO be disabled for any IR remote to work in XBMC (Kodi). In OpenElec go to menu System>Settings>System>Input Devices>Peripherals>CEC, press enter again to access the CEC settings and disable it.
Finally, in order for the Media Center PC remote to work properly with the RemotePi Board, the default power button function has to be disabled.

Use PuTTY or similar to log on to your Raspberry Pi, Default user name is root, password openelec

Key in :
cd .config
cp /etc/lirc/lircd.conf.rpi ./lircd.conf
nano lircd.conf

In the nano text editor now find every line that contains KEY_POWER and put the # character at the beginning of each of these lines, there should be 4 lines containing KEY_POWER.
Press ctrl+x to exit, y to confirm, enter to save the file.
Reboot from the OpenElec GUI

but I can’t figure out what would be the equivalent procedure on osmc ?

As soon as I execute the procedure on openelec/libreelec, the remote is working.

I think there is no much to do to get it to work on osmc… Does anyone knows ?

Thank you :slight_smile:

You probably need to put this in config.txt instead:


And we expect /home/osmc/lircd.conf. Alternatively, you can put it elsewhere and use My OSMC -> Remotes to select it.

Hi, thank you for your answer, I tried it but the remote still does not work :confused:

Did you reboot after making changes?

Yes I did.If it can help, I’m using the last available version of OSMC from OSMCInstaller on windows. Tried again on a fresh install on another micro Sd card, still same result :confused:

Provide logs please.


that was indeed a very good idea to check logs ! It appears that the system had problems reading lirc.conf.
I thought that was because I edited it from windows, and bingo : I tried again, starting from a fresh file (from openelec : lirc.conf.rpi, couldn’t manage to find it under osmc ?), putting it via ssh in /home/osmc and… that was it !

thank you :slight_smile: