Can't install OSMC on new Pi 3B+'s


I have just received 2 brand new 3B+ units. I flashed the latest OSMC Pi edition (Aug-19) onto a (known good) SD card and tried it out. Result - it gets as far as the rainbow splash screen and then hangs. Same result on both devices and with different power supplies.
I took an SD card out of a working 3B+ OSMC unit and tried that and it didn’t work at all - the screen remains black.

On trying the latest raspian image or the latest Noobs image the system boots up and works as expected.
I therefore tried installing OSMC from noobs, but after installing, it then appeared to be trying to connect a VPN and never finished booting.

The new Pis I’ve got look different to the older ones I have (they were bought via The Pi Hut and are in RS branded packaging) as there are fewer IC’s on the board so there is obviously something different about them, but I would expect them to be comaptible.

How can I get OSMC working on these?
Does anyone have any ideas on what is wrong and what solutions there are?

Thank you


What does cat /proc/cpuinfo show under Raspbian?

processor : 0
model name : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS : 697.95
Features : half thumb fastmult vfp edsp java tls
CPU implementer : 0x41
CPU architecture : 7
CPU variant : 0x0
CPU part : 0xb76
CPU revision : 7

Hardware : BCM2835
Revision : 900032
Serial : 000000001853dd33
Model : Raspberry Pi Model B Plus Rev 1.2



That’s a Pi 1B, not a 3B.

OK, Thanks for that - Looks like I may have been sent the wrong thing - better check what I actually ordered!
Seems to be a major shortage of the Pi 3 range at the moment!