Can't install update

Hello, I’ve been using OSMC for a few month now, half a year. I’ve done some fresh install as well.
Two, three days ago, I had an update but when I tried to install by rebooting, the update couldn’t be installed.
I wish not to do a fresh install again, but at this point I am stuck. Any help would be appreciated :slight_smile:

OSMC is installed on RPI2, I have an ethernet cable, a wifi dongle for the keyboard and a hard drive plugged in.
Here are the logs :

Thank you,


Could you please explain what is the current situation? What can or can’t you do?
Also I suggest first to take down your overclocking especially the overvoltage.

When the rpi downloads an update, it asks me to install it. When it reboots, and try to install it, I just get an error.
I put the overvoltage back to 0.

Thank you,


Sorry but “an error” is simply not helpful.

I’ve checked your log and there are no apt update errors in the log. So if the problem is still happening please give more specific details of exactly what steps you are taking, when the error occurs and exactly what it says. (Take a photo if necessary )

I seem to be in the same boat. Getting the message “An Error has occurred while installing the following packages: (unknown packge)” when rebooting to install updates. Here is my uploaded Logs ( i uploaded all config and logs, since i’m not sure which ones are needed here)

OSMC doesn’t reboot to install updates. (it may reboot after installing updates depending on what updates there are however)

I don’t see any update errors in your log file unfortunately. Are you sure the log was captured before rebooting ? Can you try turning on debug logging in Kodi in Settings, check for updates, then immediately after seeing the error, upload logs again ? Without a log that actually demonstrates an update error we have no idea what the issue might be.

I got the same error on my rpi. After a few tries the update started, but when in update mode and doing the installation, at one point it got stuck at 68% installing something, and never got any further. When I restarted kodi, it no longer responded to the remote.

No it doesn’t automatically reboot when installing updates but this time it asks me to exit kodi in order to install it.
I’ve turned on debug logging and did what you asked.

As ErnieBall said, the message I get is : “An Error has occurred while installing the following packages: (unknown packge)”

Anyway, this is the new log :

Thank you !

first of all, beware of file system problems.
And automatic fsck does not work every time (since the volume to be locked how fsck can check himself?)

For each problem, first, I used GParted then right-click on SD or USB key and then “Check” (Check and Repair) and each time it has solved the problem. Including lately to these update’s errors.
Windows: sample : booting the PC with “SystemRescueCd” (Linux live CD with tools, including GParted)

This is why we run fsck from an initramfs on boot. The fsck that runs during boot is not the one located on the root file system, it is contained within the initramfs image which is contained with the kernel itself - eg within kernel.img on the FAT partition.

Therefore if the kernel is able to load from the FAT partition then a good copy of fsck is being run from within the initramfs regardless of whether the ext4 partition even exists let alone whether it can be read.

So fsck does not have to “check itself” as you imply.

The fsck runs from a pseudo filesystem which is in memory, known as tmpfs. It has full and exclusive block level access to the attached SD

Hmm you lost me completely, I guess the fsck you talking about is from the line :

FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

Do you think the issue comes from my hard drive ?

This is not an error. It’s just a consequence of the fact that we don’t run fsck on the FAT32 boot partition as it is slow and isn’t necessary. If you really want to do this you can edit /etc/fstab and change the last 0 on the /boot line to a 1.

The root (ext4) file system is scanned automatically every boot in the initramfs before the normal systemd startup process regardless of the setting in /etc/fstab. If you were to change the 0 to a 1 on the root file system (/) line it would just cause fsck to get run twice on the root file system.

So this has nothing to do with our issue, that’s why I was a bit confused. Anyway, do you recommend a fresh install ?

Just to let you know, in my case “moonlight-embedded” seems to be the package that’s causing trouble.
I connected to my Pi via SSH und ran

sudo apt-get update
sudo apt-get dist-upgrade

it took a while, but finished without problems.
I can’t say, if this will work for you, but it’s worth a try

Thank you Ernie for your answer.
That might be indeed moonlight-embedded but in the end I just reinstalled everything :confused: