Can't load shared library - can't load addons


Apologies is this is stupid but we have just started with a pi3 today with OSMC, all seemed to be going well until we’ve run into the problem “can’t load addons - can’t load shared library” - We are really stuck we can’t find an answer to this! Can somebody please help us!?

It would help to know what addons you’ve attempted to use.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

We can’t get any logs either, but we’ve watched a video demo on how to set up and the video shows videos>video add-ons> and then a full list of video sources is shown in the list under this option, but ours is blank, same with pictures, same with music! We have an internet connection and it says it is updating some components, but again we have no add ons. Does this OS take considerable time to update? The only add-on we can see is the MetOffice add-on, but we are getting no updated weather on this. We are stuck, it appears to show no download progress of anything it says is updating!

Since you are just getting started, I’d suggest you start over. Because in you first post, you mention the ‘cannot load shared library’ message, that should not happen on a fresh load.

How are you loading OSMC, using the official installer? From what OS are you creating the SD Card?

Make sure you are using at least a 4GB SD card which is good quality.
Make sure you are using a good power supply.

Hi we’ve re-done the installation on a 32 gb card using the windows installer from Download - OSMC and still we have no add-ons. Card created from a Win 10 machine…same result! We originally just wrote the image file from the same location but that was the same…on a Pie 3 btw. :cry:

We’ve now just got an unknown ‘update error’ on this new install. At a loss! :worried:

As @sam_nazarko suggested, power supply would be the next thing to check. What power supply to you have?

What brand SD card? Not all SD cards are the same. Some are not what they seem, and wrongly report their size, resulting in corrupted installs.

2A power supply with a running cooling fan on the CPU.

2A supply is far below the recommended 2.5A, and with a cooling fan (assuming it’s also powered by the same supply) you are probably going to have issues.

First, remove the cooling fan (you probably don’t need that anyhow) and start again with a new install.
If that doesn’t work, get a proper power supply.

1 Like

It’s a Kiingston class 10 card.

OK thank you anyway, we’ll have a fresh start again tomorrow (it’s late at night here and I’m whacked lol). I’ll let you know if we make any progress tomorrow :neutral_face:

Avoid Kingston like the plague :wink:

1 Like

Read this this on Bunnie Huang’s blog for some useful background on Kingston.

It’s not our hardware, we are completely new to this and we are at a loss. We have swapped the pi for another one and reinstalled the OSMC to a brand new sandisk card, but still have the same problem. We download all updates as soon as we’re up and running and reboot, but still the same issue! It has to be something we are not doing in the setup! Is there a step by step guide for dummies like us? we have followed the videos to the letter and have installed everything as the video guides say, but still we have no media add-ons whereas the video guides show they have everything and they’re up and running in less than half an hour… :frowning: Don’t know what else to do!?

The SanDisk SD card is likely to be ok.

I think you’re simply misunderstanding the process. You say in post #3:

If you want to add an add-on to the system, go to Add-ons and choose “Install from repository”, then choose “Kodi Add-on repository”. You should see a list of add-on categories. Choose your category, eg Music add-ons, and the full list of possible add-ons should appear.

We have all the add-ons now, just don’t know what the issue was. When we first started this the OS was all present but the addons browser was showing zilch! We now have the add-ons browser and I am installing them thanks :slight_smile:

I just find the navigation and mouse control in OSMC is appalling!!..just saying :confused:

You’re mainly meant to control OSMC with a remote.

Yes I know lol…but we’re getting there, it’s all a learning experience.