Can't play any video file anywere

My sister was at my house and said she was having issues using my Vero 4k… I think she attempted to do something and she said she tried to update. my wife has since updated again and i had use a backup file from May 11 2017 and nothing has fixed it. I keep getting the error: One or more items have failed to play check the log for details. It appears to me that the player itself isnt loading properly. This happens when trying to use any network file via upnp, nfs or via any addon. i have reconfigured network drives and check for addon updates. i have also tried changing back to the OSMC skin (which I like alot now !) all to no avail. here is y log file from .kodi.

just tried to play a video file over usb drive and same thing happened. I can log into the box remotely and see when my wife tries to play something by using the web portal which is pretty cool. I can send files to the box via windows 10 as well so the networking side of things is pretty much laid to rest. I am about traveling and away from home for the next two months for military stuff but i can remote in to pretty much everything at my house. I would like to get this working for my wife but if we cannot figure it out I will have to resort to wiping and reinstalling OSMC and Kodi along with configuring all network shares and addons with my wife over the phone…

Please do not post logs directly to the forum. Follow our simple directions for providing logs.

Thank you for that information. Do you have any helpful information as to my request?

The log isn’t very readable but it says it couldn’t access the NFS share. Check the IP hasn’t changed on the share and that the drive is mounting / files are there.

Also check Vero 4K is connected to the network in My OSMC.

It can definitely connect to the internet as I am currently in NC and the Vero is in CT. I can log on to it via the HTTPS and stream from it. I can also remote into a PC at home and copy and paste to it via windows over LAN. it can see my networks when i re add them and configure them, i can see all the movies on my shares via the Vero. I believe it is connected just fine. I has something to do with the player not loading. I cannot drop the file here per the instructions as I am remote and cannot access that menu on the Vero to access the log file. instead I have pulled the .kodi via file browser in windows. I did have my wife do the upload log via the Vero menu however.

This is what I am focusing on:
15:01:23.879 T:4108521472 ERROR: Error creating player for item nfs:// PENELOPE MOVIES/Babe (1995)/Babe.1995.720p.BluRay.x264.YIFY.mp4 (File doesn’t exist?)

Also I tried to play via USB so as to avoid the “it’s a network issue”. It failed in the same manner.

ERROR: GetDirectory - Error getting /home/osmc/.kodi/media/Fonts/
15:23:20.544 T:3399742448 ERROR: GetDirectory - Error getting special://home/media/Fonts/
15:38:10.675 T:4108521472 NOTICE: NFS is idle. Closing the remaining connections.
15:40:53.603 T:3382965232 ERROR: Open - Error, could not open file /media/6612-F6F3/jellyfish-400-mbps-4k-uhd-hevc-10bit.mkv
15:40:53.604 T:3382965232 ERROR: ExtractThumb - Error creating demuxer
15:40:53.624 T:3382965232 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
15:40:54.319 T:3382965232 NOTICE: CDVDVideoCodecFFmpeg::Open() Using codec: HEVC (High Efficiency Video Coding)
15:41:16.241 T:4108521472 ERROR: Error creating player for item /media/6612-F6F3/video-1446408431.mp4.mp4 (File doesn’t exist?)
15:41:16.243 T:4108521472 ERROR: Playlist Player: skipping unplayable item: 0, path [/media/6612-F6F3/video-1446408431.mp4.mp4]
15:41:16.609 T:3542873072

Full logs will give some clues.
@ActionA’s link will show you how to get that to us.

The 400Mbps Jellyfish clip is quite demanding; so you may want to start with a real world clip to begin with.


The first mp4 is a regular clip and didn’t work either. No video file will play period local or network. How can I get a full log to you via remote log into the network via windows? Or via the web interface via https port 8080?

You need to login via SSH. This can be done via Putty on Windows.
It’s explained in the article @ActionA linked.

If Kodi can’t access the files, it won’t be able to play them.

Thanks Sam. Kodi can access the files for sure, it just can’t play them. Here is my full log via @ActionA instructions. The only problem is: I can’t enable debugging as I cannot physically access the box because I am away. I was able to access via SSH via putty via remote desktop lol.

Do you know of another way to access the settings for debugging? Can you remote into my Vero 4K?

Can you upload a full set of logs?

Your Kodi log actually suggests that the files can’t be accessed. Check permissions as well.

Failing that, a reinstallation of OSMC would probably be the easiest way to get up and running again.


1 Like

OK I found out I can enable debugging via the web interface. Try this link, but i think its the same My wife is on her way way home and will reboot the device and try to access a movie over my local network. I will then grab the logs via grab-logs -a and provide a link.

NB: it’s grab-logs -A. Using -a gives just the APT logs.

1 Like

OH SNAP! good to know! let me do that real quick then.

I see you can SSH to the Vero. What’s the output from:

ls -l /media/6612-F6F3
showmount -e


Thanks. Let’s try:

cp /media/6612-F6F3/jellyfish-140-mbps-4k-uhd-hevc-10bit.mkv /dev/null
sudo mkdir /dev/Videos
sudo mount -t nfs /mnt/Videos

If that mounts without reporting an error:

ls -la /mnt/Videos

and if you can see anything listed:

cp "/mnt/Videos/1 PENELOPE MOVIES/Babe (1995)/Babe.1995.720p.BluRay.x264.YIFY.mp4" /dev/null

How can I paste your text into the command prompt on putty?

Oops. The command should have read

sudo mkdir /mnt/Videos