Can't play anything following update

Just applied the December update. Since then all media causes a player crash. Vero 4k, all media via NFS mounts (not NFS in kodi). Previously had an advancedsettings.xml for local caching - tried removing following update, have put back - no difference. Also NFS mounts fail at boot but then an immediate sudo mount -a via ssh works. Yes, I did check the mounts before trying to play anything. Logs at

I don’t think your device has updated properly. See /etc/debian_version and /etc/os-release

Looks like you’re still on the October version. This would cause problems if you have only partially updated


debian_version 8.10
VERSION=“October 2017”
Should I dist-upgrade or is there a better way to try to re-apply the update?


apt-get update
apt-get dist-upgrade

should be fine

Thanks Tom.

Yep, re-updating fixed it. I thought the update was a bit small first time round (it only downloaded 35 packages). Thanks all for the superb quick support. That’s one of many things that makes OSMC great.

1 Like

Glad to hear you’re up and running now. As this was a big update, we did have a two step upgrade in place. We recommended updating via My OSMC in this one scenario as it handled everything automatically

It seems like you might have only received one update.

I’m glad it’s all sorted now and as always, if you have any problems give us a shout