Can't register on network (wpa2) : preseed_data locked

I’m new in the osmc world so sorry if i’m not in the right place. (fresh install last version)

I was having an issue logging in my wifi network.
No issue if i removed the passphrase (no security) but i vas enable to log in when the wpa2 was on.
In that case, it started the waiting screen (small ball in center going in circle) infinitly (unable to quit / cancel).

A quick look in the logs was giving me this :

19:16:06 171.776184 T:1762038816 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<–
Error Type: <type ‘exceptions.IOError’>
Error Contents: (13, ‘Permission denied’, ‘/tmp/preseed_data’)
Traceback (most recent call last):

So i fixed the issue using a simple
touch /tmp/preseed_data
chmod a+rwx /tmp/preseed_data

not sure the chmod was required …
(I wasn’t expecting it to work but I’m happy it did)

But i’m not too sure on the quality of this fix, it may brake in the next update …
Any idea on the cause of the issue ?


Sorry for the bad englendo, not a native and too tired to double check this late ^^


Two things;

  1. Use the log uploader to put the logs onto the pastebin site.
  2. Can you post which user owns the file?

When I had the issue, there was no file (I had to touch it in ssh using th osmc user)
the tmp folder is owned by root (hitting a dead corpse here ^^)
Currently the file doesn’t exist anymore (the network is still working, i suppose it’s only needed the first time ?).

For the log upload, I can’t the setup isn’t connected directly to internet => i need to use a usb stick. That’s why I uploaded the log with the error. If you want another one (if it didn’t roll) i’ll do it, just point me to the right folder(s).

Have a nice day.

I’m not really in a position to help, but a suggestion for the logs is to use the log uploader module, select all logs, but choose to have them copied to the sd card instead of uploaded.

/tmp is supposed to be owned by root, however it has write access for all users and the sticky bit set:

osmc@rpi2:~$ ls -al /tmp/
total 36
drwxrwxrwt  7 root root 4096 Sep 26 18:53 .

So any user can create a file here. During the initial connection set-up the preseed_data file is created with authentication details for the wireless network, once the network is initially connected and saved the file is no longer needed and is then deleted.

The only thing I can think of is that the networking script crashed after the file was created but before it was deleted, then you tried to connect again, thus the file already existed, or you pressed esc (cancel) in the middle of the operation then tried again while the previous copy of the script was still running.