Can't select my language in secondary profile

Hi all,
I encountered a problem with the most recent update:
Situation: raspberry pi 3; clean install

In the first (master) profile: I can select the whole list of languages.
For every extra user profile I make, I can only select “English” or “Turkish” as Language in the Region-settings.

I wouldn’t know how to make a relevant log of this; but I’m willing to submit debug logs if necessary.


I suspect this is because only the master profile has pwrmission to download new language packs, and the subsequent profiles can probably only install from those already downloaded. Try adding the language you want in the master profile and then try to switch to it in a user one.

That said, this is really a Kodi issue or a specific Kodi function and as such you should look at addressing the issue there for a more complete response. If you do believe that this is an OSMC specific issue, please let us know.

A debug log may give some clues

I’ll try to make a new profile later today and scan the debug-logs for more clues :slight_smile:

Same issue for me. Rasp 1. I had some strange things in menus* so I decided to re-install OSMC. Install and post-install were fine. I selected French as language. Interface stay in English and options are only English and Turkish.

  • for instance, video add-on menu is empty (before and after re-install).

I reinstalled an old version (2016.08) and I disabled automatic update. Now, my OSMC is running fine.

It should be fixed in the next (March) update

Ok. Thanks.


I formatted my SD-card, installed the latest version of OSMC using osmc-installer, but still I can only select “English” as language. Difference is that this now also happens in my primary profile.
In short: can’t set Regional to any other setting than English or Turkish.

Would another log be helpful? Anything else I can try?

Thanks in advance,

You need to activate languages in the add-on browser - in settings.

Brilliant! Solved my problem :slight_smile:Wasn’t aware that the languages were treated like Addons.

Thanks for the help!