Can't stream video

So I installed osmc on my Rasberry Pi. I can’t play videos though, music works fine. This is what happens when I try to play videos

13:14:18 7735.976074 T:1956885424  NOTICE: DVDPlayer: Opening:
13:14:18 7735.976074 T:1956885424 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
13:14:18 7735.977539 T:1481634800  NOTICE: Creating InputStream
13:14:19 7736.460938 T:1481634800  NOTICE: Creating Demuxer
13:14:25 7742.744141 T:1956885424  NOTICE: Samba is idle. Closing the remaining connections
13:14:49 7766.595703 T:1481634800   ERROR: Open - Error, could not open file
13:14:49 7766.595703 T:1481634800   ERROR: OpenDemuxStream - Error creating demuxer
13:14:49 7766.595703 T:1481634800  NOTICE: CDVDPlayer::OnExit()
13:14:49 7766.597656 T:1956885424   ERROR: Playlist Player: skipping unplayable item: 0, path [upnp://94ee3b43-05a3-423f-959c-74db39cd93e4/15_7e94ef87_dc132216_2fe129e-23965/]

I’ve tried this via SMB and UPNP, I made sure change the permissions but this still happens. I can play the music files located in the same folder. Any ideas? I’ll include the debug log

11:15:22 599.610596 T:1956885424   ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://'
                                            unix_err:'71' error : 'No route to host'
11:15:23 601.023621 T:1956885424   ERROR: GetDirectory - Error getting smb://

You have some sort of networking issue. You need to explain thing a bit more on the particulars of your network and provide a complete set of debug enabled logs.

Sure, sorry. I’m currently using WIFI to stream files since my computer is on the other side of the house.

You should test with a wired connection in order to confirm or refute wifi as the culprit. Also, UPnP should be is the very last sharing protocol I would use. It’s implementation has been notoriously flakey in Kodi for years.

Alright so, I tried it on wired connection and it worked just fine. I brought it back to the TV and set it up via SMB and now it works perfectly over WIFI. I don’t know how that fixed it but it works now.

Glad it’s running! Enjoy!