Can't stream videos on Raspberry Pi B+

My aim is to use a Raspberry Pi B+ as a media center. I installed OSMC on it and also installed video addons for YouTube, Vimeo and Vevo. When I start streaming videos, the streaming and playback is really flacky. Some frames get dropped, the progress bar does not move and it gives me a feel that there is something wrong. My internet speed is 71Mbps, so download speed isn’t a problem. I tried OpenELEC and Xbian and both gave similar issues. I then flashed an old Raspbmc image and installed the Vevo addon (as YouTube addon is no longer supported) and the streaming worked like a charm. Is this something to do with the newer versions of OSMC or Kodi in general?

Many thanks,
Nikhil

This sounds really strange and sounds like some addon issues. But maybe first check the network (btw are you using wifi or ethernet?).
try wget http://ipv4.download.thinkbroadband.com/50MB.zip and post the outcome.

Also please provide logs:
To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Hi @fzinken,

I am using WiFi. I tried uploading logs. I got a link too (http://paste.osmc.io/%20rizipuxumi)
but when I open the link, I get an error. Will it be useful if I post a private video of what’s happening on YouTube and share the link?

Regards,
Nikhil

Seems something went wrong with the upload (maybe related to your wifi problem)
What was the result of the wget?

Try to upload again and post here

How do I do a wget on OMSC? Is there a terminal equivalent?
I tried capturing the log again, still no luck with the details. Here’s the new link: http://paste.osmc.io/ dopacatiyu

Sorry about the trouble, but I am a complete newbie.

Many thanks,
Nikhil

First, why don’t we try plugging an Ethernet cable in and seeing if the WiFi is the root problem.

1 Like

@ActionA & @fzinken,

Many thanks! I connected my Ethernet cable and the streaming improved.

Regards,
Nikhil

Well good to know, just still strange why your wifi is having problems with newer kernels/drivers

Yes, exactly. I tried connecting the WiFi adapter again this morning and the buffering issue persists. I now suspect if the Raspberry Pi isn’t getting sufficient power to support the wireless mouse adapter and the WiFi adapter together. I’ll try disconnecting the mouse tomorrow morning and check if it is any better.

Many thanks for your help. :smile:

Do you have max_usb_current=1 set in /boot/config.txt?