Can't update brand new 4K+

Just unpacked my new Vero 4k+ but am getting errors when trying to update it via MyOsmc and commandline.
I have searched for the error and came across a couple of posts saying try to use google DNS servers which I have done with out any luck.

Logs are here hopefully.


The first thing I see in your log is an banned repository. I’d suggest that you remove that.

Try updating from the command line, and share the output here:

sudo apt update
sudo apt dist-upgrade

Well if there is it was shipped with it.
I have only installed Confluence skin and autofs nothing else has been changed

It was not shipped with the banned repository in your sources.xml. It got there one way, and one way only, you added it. And adding the Confluence skin or autofs would not have added it.

osmc@vero2:~$ sudo apt-get update
Hit:1 stretch/updates InRelease
Ign:2 stretch InRelease
Hit:4 stretch-updates InRelease
Hit:5 stretch Release
Ign:3 stretch InRelease
Err:7 stretch Release
503 Service Unavailable
Reading package lists… Done
E: The repository ‘ stretch Release’ does no longer have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Havent tried dist-upgrade yet dur to this error but if you say its ok to I will

We don’t ship any unofficial repositories.

Please post the output of attempting to update via the command line so we can check what the issue is

One of the APT mirrors is suffering a power outage. You will need to wait for now.


Sorry I did copy the sources.xml from my other vero. I think that sources.xml is the same one Ive been using for years on my pis. I will sort that out. Dont remember ever adding one


I don’t think you are using anything from it, so it’s best to remove it (from both systems!) That way in the future we won’t remind you of it.

But looks like Sam pointed to the real issue, a temporary power outage.

Yep and thank you. Deleted it.


I’ve redirected the traffic so updates should work again.

Thanks Sam. Looks like it’s downloading now.