Can't update/install Add Ons

Hi guys!
So I recently tried installing a few addons and they all seemed to fail (blamed it initially on new repository).
However then I tried updating some of my existing addons and nothing seems to work (Update/Installation Failed message).

The theme is Basic Confluence.

Here are the logs:

and an extract of the error message I’m getting in the logs:

08:17:29 219.889771 T:1750168560 ERROR: CAddonInstallJob[]: failed to download special://home/addons/packages/
08:27:40 830.624207 T:1635775472 ERROR: CAddonInstallJob[]: failed to download special://home/addons/packages/

The Pi is connected to internet so I ruled out connectivity problems. (everything else works no problem)

Any ideas?

Does it work again, if you remove the banned repository?

Nope :frowning:

here is updated log file

Search your logs for
ADDONS: Using repository sup…
Error getting /home/osmc/.kodi/userdata/addon_data/…

So with those installed don’t wonder about issues you run into

Hmmm sorry, don’t quite understand your reply

(forgot to mention I’m quite a n00b :wink: )

Well @mcobit asked

Which you answered with

But your log still shows those banned repositories/addons

You’re right! I removed the repo but it shows up on reboot.

Latest Log:


13:02:21 12118.157227 T:1696592880 WARNING: Delete: Can't access file "/home/osmc/.kodi/addons/superrepo.kodi.isengard.all/changelog.txt"
13:02:21 12118.158203 T:1696592880   ERROR: Delete - Error deleting file /home/osmc/.kodi/addons/superrepo.kodi.isengard.all/changelog.txt
13:02:21 12118.158203 T:1696592880   ERROR: CAddonUnInstallJob[superrepo.kodi.isengard.all]: could not delete addon data.

Any ideas? Could it be a file permission problem?

Could be. How did you install that stuff?

You might have to remove the folders of those addons with root rights.

Cleanest way would be a reinstall of osmc and stay away from piracy addons and repos.

btw @filthpig you really should read this

yep, think I will do that.

thanks @Toast , good read! will keep this info to heart on my clean install

i got worse examples if your interested :wink: remember free isn’t always free just because its easy to install