Can't update library, MySQL, Vero 4k+


I had my MySQL setup working fine with updates to the library working and saving everything correctly to the database.

But the problem started a few days back when my router had to be reset to factory defaults. The thing is that I have a rather special VPN-router that uses static IPs for everything, so after the reset everything was back up and running with the same IP-config as before.

The Vero could access all files (I checked asap when I got the network back up again). But it had run a cleanup on the database removing all records of movies and tv-shows so it was completely cleaned. I then tried to update the library again, but nothing happens. It just asks if I want to start it manually and then nothing happens at all. I have the library auto updater installed, it just shows the time of its next update, could that be blocking some error message or something? Or perhaps the addon has gone broken on me?

I then tried to change the db-name in the config just to force it to do something with the database, and it sure creates the tables and everything looks crisp and clean. But still I cant update the library, nothing happens, just as before.

So that kind of put me into a halt as I have a confirmed working connection to the database but still can’t update the library.

Here are the logs:
I did make an attempt (failed) to update the library right before uploading the logs, so it should be in there if there is anything useful.

Extra notes:

Version of OSMC: Latest July Update (if it didnt show in the logs)

EDIT: It should be noted that I only use the mysql library with this single device. I am evaluating how it works so the other Kodis are local still.

The database is hosted on a machine in the network, but not the Vero itself.

Thanks in advance!
/Oscar H

I take it this log was from the renamed (empty) database you created when you changed the database name tag? I see VideoInfoScanner: Finished scan. Scanning for video info took 00:00 so i’m guessing that is because you didn’t go back and ‘set content’ on your sources after changing the name.

If you had everything working and the only thing you changed was in your router then I would think you should probably be looking at that for something that could be blocking internet access.

I can see that you used the <name> tag in both the old and new Kodi logs. In the old log, you used the (default) names of MyVideos and MyMusic and in the new log you changed the names to MinaFilmer and MinMusik.

There was a thread a week ago (here) where the user had problems when using the <name> tag that was resolved by removing it from advancedsettings.xml. See if that helps.

Alright, I’ll try that and see

Tried it real quick with no results. Still nothing sadly.

I just did the name change to force it to do something with the db, just to see that it had access.

I tried to uninstall Library Auto Updater as well with no result.

2019-09-09 20:24:42.737 T:3963794144   ERROR: Unable to open database: MinMusik72 [1049](Unknown database 'MinMusik72')

Do you have the user ‘movie’ on the MariaDB server set to be able to create databases? From the error above it does not look like you do.

I managed to solve it!

I can’t really speak for what it was that fixed it in detail. But I saw DarwinDesigns post and thought about the ‘set content’-part. So I checked and they were set as they should, but I did reset the settings with no success.

So I checked the router, but the Vero had perfect access to the internet, so couldn’t do much there.

Then I turned towards the DB, so I cleaned the db of everything that had to do with Kodi (Shared server with many other local applications running, you know how it is to be a programmer, they stack up :slight_smile: ). But kept the user that was used.

Still no progress, but I checked the new logs and saw the same thing with it finishing so fast, so I did reset the settings for the content again. And voila it worked. I don’t have a clue what part it was that fixed it. But it did scan my whole library now (400+) movies without any problem.

I also did the change where I removed the nametag from the advancedsettings-file so that might have a finger in this as well.

Thanks for the help guys, sadly I can’t leave much to help others as this looked more like a freakish issue than a standard bug or anything.