CEC Adapter behaviour

#1

If I set it to switch off or suspend when TV is switched of that works fine as long as the vero is on.
However, if it is already in suspension, switching the TV off wakes the vero up which in turn turns the TV on.

Turning off switch source to this device on startup did not help.
Having the setting devices to power on during startup: none or TV gives exactly the same behaviour on my TV (Samsung q8f), and send inactive source changes no behaviour either

I appreciate the possibility to get the vero to fall asleep as soon as TV turns off, is there any way to fix this behaviour?

#2

Can you post some logs so we can see what’s going on here?

#3

https://paste.osmc.tv/nezugehera

Created right after first turning TV off twice when vero was on, and lastly once when it was off, which turned it, and the TV, on

#4

Sorry – my fault for not mentioning, but can you enable debug logging, reboot and re-upload?

Cheers

Sam

#5

Https://paste.osmc.tv/olonimoyik

#6

Mine does the same. I wish there was a way to force the vero to not come on via HDMI commands and only come on from the app or remote.

#7

This can be disabled under Settings -> Input -> Peripherals.

@Stgurgel Your log suggests that the wakeup is caused by a screensaver. Can you check this?

#8

Turned screensaver off, no change in behavior. Turning tv off when vero is suspended turns it on. Turning tv off when vero is on turns it off
New logs in case you need them
Https://paste.osmc.tv/lawisuvoqa

#9

Looks like your TV is sending a ‘keypress’:

‘2019-08-16 14:58:21.725 T:3727561440 DEBUG: PushCecKeypress - received key b duration 95’

#10

Right. Well I am pressing a key, the off key. But the vero wakes up when it notices it. Seems unwanted. Or is my TV acting weird about the off-button?

Also. I have a second problem and right as I am writing this I finally have a log of it.
Sometimes the vero just wakes up.
Logs https://paste.osmc.tv/irobecigar

#11

It will do that to check for updates if you have that enabled.

#12

Still looks like those keypress are a problem
You could noop them in Keymap Editor I suspect to prevent them from causing a problem.

#13

I’d recommend adding a setting for only checking updates if not suspended.
But hopfully now when I’ve turned auto updates off it will fix the random waking.

#14

Still struggling with random wakeups, even after turning auto updates off, and not using library auto updater but only watchdog.
Seems only solution is turning cec off, which sucks because it is really convenient to be able to use the TV remote if that is what I have in my hand already.
I guess it is possible the reson is TV is sending keypress even while in standby, but I highly doubt it and suspect it is other way around, Vero wakes and therefore TV wakes (and the settings do not affect that, TV seem to ignore them and wake when vero does, whatever the settings for CEC adapter is)

So, should I give up hope?

#15

Your log shows that it is clearly the TV sending these commands, not the Vero.

You can noop these keys to prevent wake up. I will see if it makes sense for us to do this by default. I need to make sure that I don’t inadvertently prevent wake up from remote via CEC on other devices

Sam

#16

OK, thank you, I will give it a try.
Is there a trick to noop keypresses originating from cec?
Or do I put it in my remote.xml (or should I make a keyboard.xml to put it in)?
And can you please help me see in the log which key/s I should noop?
Is it always the b key that causes the wakeup? And if so, is this the correct syntax?
[keymap]
[global]
[keyboard]
b]noop[/b]
[/keyboard]
[/global]
[/keymap]

And finally another a little stupid question, but will this even help? If the vero is suspended, dont it need to wake to read the keypress and decide to ignore it (and therefore output picture its which is what causes my TV to turn on)?

#17

No.

You can use key map editor to noop the keys if insure

Sam

#18

Great.
I am not completely unsure, as I have created a remote.xml already to get my remotes to behave more like I want them, because I tried the key map editor but it had problems and did not work for me.

What I am the most unsure of is if it is a Keyboard keypress I should noop, and if it is always the same key causing the vero to wake?
I tried but reading the logs is beyond me
latest log: https://paste.osmc.tv/camuxicaro

#19

This can be disabled under Settings -> Input -> Peripherals.

Thank you. What is the option to stop the Vero switching on?

#20

Can you explain this in more detail?