CEC changing source on power on

Hey guys,

Everything was working fine until the May update, since then I’ve found that whenever I power on the tv/amp (Panasonic tv and Onkyo amp) it always changes to the rpi/osmc. I originally had this problem and the hdmi_ignore_cec_int = 1 fixed the issue. However it has started again now with this update. The ignore cec command above is still there and I’ve tried restarting everything, powering off for 30mins etc to no use. Any more suggestions of things to try?




A few users are experiencing various issues with cec, my understanding is we are awaiting an upstream fix.

In the mean time, if you haven’t already you could try disabling switch source to this on startup. This option can be found under:

cec adaptor

Thanks Tom.

Hi Tom,

Thanks for the reply. I’ve checked all the CEC settings and all look correct, the switch source at startup was already disabled.

Sorry to hear that lots of others are struggling with CEC as well, do we have a timescale for it getting fixed upstream?


The upstream is being monitored for any potential fix, but as far as I am aware there is no time at the moment.

Regards Tom.

Ah that’s a shame. Is it possible to roll back to before the May update?


It is, but not recommended as there were various security fixes and improvements in the May and June releases,

If you still wish to proceed, back up your configuration using Myosmc. Then use the osmc installer and select the april build and reflash the sd card. Once you’ve booted this up, you can restore your settings; using MyOsmc.

Thanks Tom.