CEC issues since xmas update

#51

Do we still need logs to investigate this?

0 Likes

#52

For now, no. I’ll see if I can reproduce this

0 Likes

#53

thanks - hope this get fixed soon - for now i have to unplug the vero every night from the power

0 Likes

#54

I can make a test build available in a couple of days.

Cheers

Sam

0 Likes

#55

@sam_nazarko has a fix been incorporated into the latest builds?

i had another instance of Vero 4K spontaneously powering up my system again today despite being on the latest build. unfortunately it is difficult to predict when it is likely to occur hence why I’ve not been able to get logs on this issue.

I’m also experiencing the issue whereby the AVR switches to its home page as described in post #43.
new logs - http://paste.osmc.tv/pimifirare

0 Likes

#56

No – it will be prepared for the January / February update; in the sense that you will have an option to disable this functionality.

Sam

0 Likes

#57

Hi Sam,

could you please elaborate a bit on what actually makes the Vero 4K+ resume from standby?
Mine seems to be very reluctant to keep sleeping.

Is there a list somewhere with wake up reasons?
WOL, notifications over http from the web app for instance?

cheers,
Anthrax

PS: this happened to me as well after having a perfectly working Krypton Vero and than giving in to the itch that I got for not having Leia :wink:

0 Likes

#58

Hi

Resume occurs on any action that would wake Kodi from screensaver.
This is most commonly a registered key press.

Usually a Kodi debug log will show you this.

@gmc: is the standby patch in sync?

Sam

0 Likes

#59

Have a somewhat related issue that might help finding some root cause to some of the CEC oddities:

When letting the Vero (not +) going into suspend when TV turns off, everything is fine. When I turning on the TV on the next day the Vero turns on. Does not steal the display as I have active source disabled. So far so good.

BUT, when I switch the first time to the Vero there is no HDMI signal present, like the HDMI connection didn’t properly “wake up” before. Switching back to TV input and then to the Vero again and everything works fine. No keypress or anything else send to Vero before switching input to it. So there is some wakup related issues here.

This only happened prior to December Update when the TV was recording, meaning it turned on itself without the display and not telling other devices to wake up, so it can record. Now it happens every time. When a recording is involved it gets even weirder and I end up on the Vero 1st instead of the TV when turning the TV on. When then switching to the TV, Vero steals the input shortly afterwards (guess HDMI woke up then).

For now I turned off the “Suspend” Mode in the CEC Settings and it behaves more properly. Prior to the December Update it worked without issues (well except after TV recording, but I rarely record anything so didn’t bother to investigate more). So maybe related issues in regards to the re-enabling HDMI here?

Didn’t have the time to properly debug it and listening what CEC stuff comes “over the line”.

Setup: Vero 4K -> Denon AVR -> Samsung TV (TV uses ARC audio for TV to the AVR). So nothing unusual involved here.

0 Likes

#60

Hi @sam_nazarko,

At the moment I can’t really enjoy my setup because my Vero wakes my TV automatically in the middle of the night when suspended - so I turn it off every night and have to power cycle it every day which gets old really quick :wink:

The problem is that I don’t find the source of the reactivation in any of the logs (kodi, dmesg, journalct, whatever) and this is driving me nuts… Do you have any more tips on what might wake the Vero or how to log this?

And please don’t get me wrong - I WANT my Vero 4K+ to wake my TV but I don’t want my vero wake up by itself :wink:

regards
Anthrax

0 Likes

#61

Kodi logs should show a source of wake up.

0 Likes

#64

Any progress here?
@sam_nazarko do you need more logs to fix that problem?

0 Likes

#65

Looks like the last request was for someone having the problem to post logs, and that hasn’t happened. yet.

0 Likes

#66

Despite disabling standby in the CEC settings and turning off all options to switch on stuff, I’ve been finding my OLED TV on in the morning despite switching it off the night before.

I’m really paranoid about retention / burn in :worried:.

Patiently waiting for the update in Post #56 above although it can’t come soon enough :hourglass_flowing_sand:

23d


more logs here:

http://paste.osmc.tv/verevulata

2019-02-11 08:52:15.818 - TV Switched off
2019-02-11 08:59:38.525 – Spontaneous Switch on.

0 Likes

#67

Same here, turning my whole set off every night now. As soon as I got some time on my hands again I’ll try another dig at finding the root cause…

@paulwebster gave another hint at what might be happening here and it sounds plausible:

ciao
Anthrax

0 Likes

#68

@mosmos At settings->system->input->peripherals->CEC adapter you find the option “Wake devices when deactivating screensaver”, see also Vero 4K + CEC?

Is this option ON or OFF in your configuration?

0 Likes

#69

Wake devices is deactivated.

0 Likes

#70

I will look in to this in more detail after v18 is released (shortly). We’ll get it solved – don’t worry.

Sam

0 Likes

#71

I also suspect CEC message
10:04 - Sending active source message for ‘Recorder 1’

may have a toggling effect on my AVR. i.e. If the AVR has already selected the OSMC input, when the command is sent, it results in the AVR changing from the OSMC input to displaying its home page.

0 Likes

#72

@sam_nazarko Here is my current theory of what is going on:

The TV wakes up to perform various maintenance activites in the middle of the night e.g. auto tune Freeview/Freesat channels etc. (As many freesat/freeview STBs do)

If the Vero was the last source when the TV was placed in standby, the Vero (and AVR) are also waken up.

A CEC instruction is sent to make the Vero the active source (by Vero?).

The TV then does not shutdown after it finishes its maintenance operation because it thinks the Vero is now active. The TV then becomes dependant on receiving a standby command from either the Vero or its remote control.

If there are are no other shutdown timers, (e.g. for inactivity), the TV remains on.

After turning off Freeview / Freesat on TV, it has not woken up in the night. Still monitoring however.

1 Like