CEC problems

I have had my Vero4K+ a few days and I love it but it is giving me hell with CEC enabled on my Denon AVRX2600 receiver. I am playing through HMDI2 to an LG49UM7400PLB, if I put the HMDI direct to the LG, no problems its only with the Denon in the link that I get it. The display goes black and the sound cuts out every 45 secs for 3 secs then comes back for 2 secs, goes black again then it is ok for 45 secs to a min. The LG is changing from HDMI ARC to Opt+internal and the HDMI2 input lable is going from KODI to blank at the same time. If I disable HDMI control on the Denon all works fine (but I cant then use my TV as the problem still occurs even with Vero in sleep and Sat TV and ARC selected)
I have changed the HDMI cable and tried another HDMI input on Denon, still the same, I have used many players on the same set up over the last few weeks, nothing like this has occured before.

You might try the Vero on HDMI5 (media player) on your Denon.

for explanation see 3 on (not that you have HDR issues) about seems to correct poor signal clocking within the HDMI signal path

1 Like

I had just finished trying HDMI5 Media Player before I posted, that was the other input that I referred to. Strange thing but last night I got it all working fine (even watch some TV with ARC on and played a film on the Vero), tried it this morning and it was back with a vengeance.

see above picture for my setting of denon avr (i have x4500). I use logitech harmony to control all devices, so no HDMI issues. but I did had them first. Mainly put all devices powerless and even disconnected hdmi cabling between receiver, TV and vero for at least 10 min.

My vero is on HDMI5, On Denon monitor 1 is used. I also have set 4K signal to enhanced.

You might try to settings to test/experiment.

Also try those settings:
Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

Thanks for the suggestions, I have just tried HDMI7, closest to out, no good, I will try others later.

You mentioned CEC in the describtion, but you describe that your LG is behaving badly when Vero is connected to AVR. So therefor i think we must look into the connections and settings. Is it only the vero that makes this problem, or do other devices have the same problem when the LG is attached?

on denon which device is connected on which HDMI port, incl LG.

maybe you can list the settings in the denon and what you select when you want to play something on the vero. Also when you disable HDMI control on Denon, then you can’t use arc sound from tv-apps when the vero is connected?

I just have Vero4k+ in HDMI7 (now) and Monitor1 to LG, I have had other boxes (WDLive, Humax HDR, Egreat A5, Nvidia Shield, Zappiti ect, ect, never had any problems with the setup. Just trying to watch anything with ARC on (HDMI control must be on to get ARC) gives me these problems only way to stop it is turn HDMI control or ARC off or unplug Vero4k+ (slumber still gives the problem)
I could use an optical output from the LG and turn ARC off on the Denon but I would like to get it working as its easier to use (I have a Philips Pronto Pro so I do not really need HDMI control, I have to set this up yet though)

you can try turning CEC off within Vero, to see if you can watch on tv and listen via ARC on AVR.

also check your settings on CEC within kodi

Also you can try to select HPD lock and reboot after setting.

I’m not familiar enough to read out CEC client info from Vero. You can try to run cec-client from the command-line. then probably another OSMC experienced member can help you further

and provide a full log

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging
  • reboot the OSMC device twice(!)
  • reproduce the issue
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Turning off the CEC within Kodi I could watch the TV and play the media with sound through the Denon. This is the same as turning off the CEC on Denon, I cant use the LG remote on Kodi. I tried the HPD lock and reboot, I had video for 30 secs then the LG reported no signal, I had to unplug the Vero and then reset that setting as soon as it came back up to get back to stability.

Here is the URL https://paste.osmc.tv/uredevatup
How do I view the logs?

Just clicked the link, not much info there

Realised, I did not click ok, try this one
URL: https://paste.osmc.tv/irojivokol


Unfortunately the log is empty. I would try rebooting, reproduce and re-upload.

Have you tried different hdmi cables?

Thanks Tom.

That log is empty also, do I have to select device specific logging?

The problem is showing a switching of HDMI 2 on the LG, it displays Kodi then other box for a few seconds then changes back to Kodi
Mistake in the link URL:https://paste.osmc.tv/idotapeyez

Your gui is set 3840x2160 @ 60p

It’s suggested to set it to 1920*1080@60p

I have tried that, no better. The log is displaying OK now, it shows LG as bugging out toward the end of the log, whatever that means
It’s working fine again tonight, can the IR sensor be turned off, could be sunlight triggering RC commands

I have managed to get it working properly, the only thing not working is the LG remote, the LG tv thinks it is connected to SEI Robotics. Has anyone checked the log above to see what the problem is with the CEC adaptor?

Hey John,
is this the behaviour you’re getting?
Check this old video from me

So far I could only notice this strange behaviour when connecting Apple devices.
I tested it with a Mac Mini model from 2009 and a MacBook of the 2012 generation. Both devices show this behaviour on my Denon X2200W. This behaviour is completely independent of the target device to which the image is output. I tested this with an LG OLED65B8LLA (mid-2018 model), the old Sony Bravia model that can be seen on the video and an Asus PC monitor. The latter two models both don’t have ARC functionality.

I therefore suspect that this is a DENON-specific problem, for which the VERO is not at fault.
A support ticket at DENON didn’t help me either. The colleagues from there only blamed the Apple devices and said it must be a hardware problem on their side.

If there is a solution for this behavior of the Denon AVRs, I would be very interested in it.