CEC + Samsung Q7F + Denon x1400H + vero4k


#1

Hello all,

In my previous setup I had a yamaha received (RV477) with the Samsung Q7F and CEC was working I could manage kodi with the Samsung TV remote but I’ve just bought a denon x1400H and I’ve realized that CEC is not working any more.

Do you know in any special configuration must be done at Kodi level? I was thinking to do a full restore and start from scratch my kodi setup just to be sure it’s not caused by an old config but before doing I would like to know your opinion.

Thanks


#2

Have you tried to disconnect all devices from power for 10 minutes and reboot them?


#3

no, I’ve not tried to disconnect all the devices from power. I will try this PM. thanks


#4

Anything else connected to the AVR?


#5

no, I’ve just have the TV in the ARC HDMI and the vero4k connected to one of the other HDMI available


#6

I’ve just tried to disconnect everything for 10min and nothing, CEC is not working anymore. Is there any way to debug!? To see if vero4k is receiving anything


#7

Try a different hdmi cable if you can


#8

actually I’m using the same cables as in the yamaha configuration anyway I’ve tested it with other cable and same result


#9

Hi,

available hdmi on your TV or the AVR?

Tom.


#10

yes, in the TV it is called samsung anynet+ and it is enabled and in the denon hdmi control is ON. Doing test yesterday I’ve noticed that using the tv remote I can control the Denon menus (it means that CEC works in that direction), but I cannot the vero4k. Is there any way to check if vero4k is receiving any CEC signal? Maybe it is but it is no able to recognice it.

Anyway. I’m going to open a threath in Denon forums as well.


#11

Hi,

If you enable debug logs you should be able to see if the vero4k is receiving the cec inputs, more details can be found here.
Also if you drill down further in the log options there are component specific logs, which can be enabled; one of them should be cec. If you upload the logs as advised in the link and post the given link, we will be able to advise further.

I would also try shutting down the vero4k, disable anynet+ and then re-enable it, power back on the vero4k. Hopefully anynet+ will see the vero4k and cec should work again.

Thanks Tom.


#12

I’ve enabled the debug mode and I do not see any event related to CEC. I can see LIRC event though.

But If I connect the vero4k directly to the TV I can see the CEC events:

20:55:32.786 T:3944739584 DEBUG: CecLogMessage - CheckKeypressTimeout T:91.919
20:55:32.786 T:3944739584 DEBUG: CecLogMessage - Key down: idle (duration:0) (2) timeout:875838001ms (rel:500,rep:0,prs:500,rel:0)
20:55:32.786 T:3944739584 DEBUG: CecLogMessage - >> TV (0) -> Recorder 1 (1): user control pressed (44)

Looks like a AV receiver issues, it’s not able to passthrough the CEC control to kodi.

I’m very disappointed with denon. I will consider if I return it to amazon or not.

Another option is to buy a logitech harmony and automate all the configuration.

thanks for your support