CEC stops responding after some time

When I start Vero 2 I can use both CEC and Vero 2 remote. After couple of minutes CEC stops responding, only remote works. And only Vero reboot helps.
Is there any bad interaction going on when I use both inputs ?
I have Samsung TV, never had an issue with CEC in OSMC on RPi.
I will try to get logs tomorrow, just checking whether this is a known issue or it is just me.

How old is this Samsung TV?

When CEC stops responding, does this help:

echo 0x0 > /sys/class/amhdmitx/amhdmitx0/cec_config

Glad its not just me having this problem. CEC works for a few minutes if I’m lucky then stops working until i reboot. really annoying!!!

I’ve got a philips tv about 10 months old


Samsung is 2013 model
echo 0x0 > … did not help

Above logs show a little bit different situation - I rebooted Vero, I was able ot use CEC and I was not able to loose CEC just by browsing menus. But then I switched to TV and back and CEC is not working

Update - after a reboot I spent more time in menus and I lost CEC, without switching away from Vero


Another update - after I put link here and came back to osmc, I was able to use CEC again. But it worked for 5-10 clicks and then went away again, very strange.
I am putting another log, it will contain previous plus what I experienced later. HTH

i had a simmilar problem a while ago and i found that the problem started after i changed some settings regarding cec from withing kodi (settings -> system -> input devices -> periferals -> cec adapter).
The problem gone away right after i reverted those settings back to default. I really cannot remember the exact setting that made this problem appeared but the settings are not that much in there and finding the cupid one will not be hard.

i hope i am not off topic, if i am i am really sorry.

Good luck.


Vero2 is handling CEC in kernel currently, as opposed to libcec on all other OSMC platforms. While steps are being taken to backport libcec to Vero2 builds, the above configuration options are currently not available on that device.

I am really sorry for the offtopic.

Sam, any updates on this ? Any tests I can do ?

The development of libCEC isn’t going to be an overnight fix

We are still investigating some of the disconnects


Sure, I understand implementing libCEC takes time, I was meaning to help troubleshoot current kernel stuff.
I played with it a little, for a while I thought it was the cable which came with Vero2, but no. It just took longer in that particular case to disconnect, but on next try it was under a minute. So there is no way I could reliably reproduce the issue, it takes 1-20 minutes to happen.

Don’t worry – I am aware that CEC can be touch and go at the moment.

I will let you know how to get some more helpful logs soon, but first I need to improve verbosity in the kernel.


After a few days running the Vero 2 as a drop-in replacement for the Vero 1 I’m quite happy. The device really is noticeably snappier than the Vero 1.

One problem I face now with the CEC implementation:

When I turn off my TV (usually I set the receiver to the TV box as input and then turn the TV off) , sometimes the TV goes off - the receiver waits a while and then goes off (so far so good), but then the TV turns on again, the receiver as well and is set to Vero 2 as input. If I then change the input to the TV box and turn the TV off again - it turns off, and turns off the receiver (as the old Vero always did).

So I’d like to know if anyone has a guess as to which CEC signal might trigger this and if the Vero 2 can be set to ignore it.

Same issue for me. Also controlling kodi via cec doesn’t work all the time. There are dropouts where I have to reconnect cec via tv settings or a complete loss of connection where only a reboot seems to help.

Team OSMC stated that there will be a libcec in the near future that should make things better (of course it always depends on the tv and avr or better said the combination of the 2). Also with libcec we will be able to change some cec settings in kodi via settings - system - devices.

Don’t know if this is very useful but I’m also adding my setup to this thread.

TV is a new Sony 55WDL808C tv which is connected to the new Vero2 via HDMI and CEC worked very well on the older un-updated Vero and is now faltering as soon as I either switch to another TV input (when I come back Vero2 OSMC/Kodi stays dimmed and stays that way) or if I let Kodi to go in “low brightness” mode.
In that case CEC is totally dead but the new remote works perfectly (great remote BTW).

I don’t know if this is related but the name of the device is Sony’s list of inputs disappears and I can switch to it only through a generic HDMI4 entry (but as I said before it remains dimmed and unresponsive through the TVs remote).

Thanks for looking into this.

I just installed April’s update and CEC seems to work finally. Thank you
Now waiting for Android… :slight_smile: