Change CEC client name?

Hi there,

I’m often using two OSMC boxes at the same TV (Samsung UE55). It’s hard to learn for my family, which “Kodi” is the one with the movies, and which one is the “dad is testing his stuff”.

IIRC, in the early times of Raspian/XBMC, one had the option to edit the CEC client name - or the hostname was used for it. Am I right? How can I get this back again with recent OSMC/RPi2?
I’m using the Februar 2016 version with auto-update, Skin changed back to Confluence.

Would appreciate any help,

Never tried it but what about in:

I am testing it myself now ,

Actually I can not test that … my tvees do not support that feature … Bummer …
Good luck!

Let me know if it worked :smiley:

@Hein_Koster it works ! (on a Samsung TV)


1 Like


Is this still best practice for modifying my Pi CEC name?

I’m probably missing something simple, but I can’t see the directory /home/osmc/.kodi/userdata/peripheral_data/rpi_2708_1001.xml

This is some kind of hidden file?

Just because it’s hidden (any file or folder with a . In front of the name is hidden) shouldn’t stop you accessing it. It would be most straight forward to view (and edit) this file via logging on to the command line.

Hi there,

it does not work with Samsung F6400 series (UE55F6470). But in detail:

I found this file at the given place, and it has 644 permisions. So I changed

setting id=“device_name” value=“Kodi”


setting id=“device_name” value=“EVA9003 Kodi WZ”


nano /home/osmc/.kodi/userdata/peripheral_data/rpi_2708_1001.xml
(saved by ^O ^X)
(rechecked by)
cat /home/osmc/.kodi/userdata/peripheral_data/rpi_2708_1001.xml

But my TV always shows up “Kodi”, even if I run the “Scan for Anynet Devices” which is a CEC+ device discovery.
Same after disconnecting the TV from mains for 5 minutes and then scan.

After a reboot of my RPi2, this file again contains the old

setting id=“device_name” value=“Kodi”


Thus, it does not work with my Samsung F6400 series (UE55F6470). But since some of you report it working, this can’t rely on Samsung here, or?

Anything I missed?

In Kodi go to Settings>Services>Device Name and change the name there then reboot.

I just jumped down the stairs to give it a try. Nope.
I was in (translated from German)

Options | Settings | Services | Generic | Device Name

but this is already at the desired value and only affects the hostname (/etc/hostname).

Linux eva9003 4.4.16-4-osmc #1 SMP PREEMPT Fri Aug 26 00:22:10 UTC 2016 armv7l GNU/Linux

I would highly appreciate to have CEC name and hostname in sync, but … no luck.

BTW, my version is:

uname -a
Linux eva9003 4.4.16-4-osmc #1 SMP PREEMPT Fri Aug 26 00:22:10 UTC 2016 armv7l GNU/Linux

grep VERSION_ID /etc/os-release

grep Kodi .kodi/temp/kodi.log | head -3
19:53:13 10.681442 T:1956823984 NOTICE: Starting Kodi (16.1). Platform: Linux ARM (Thumb) 32-bit
19:53:13 10.681510 T:1956823984 NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)
19:53:13 10.681585 T:1956823984 NOTICE: Kodi compiled Aug 28 2016 by GCC 4.9.2 for Linux ARM (Thumb) 32-bit version 3.16.7 (200711)

I’ll see what I can do, but I don’t have a CEC compatible device that works well to test. I have a 2009 LG32H-3000 but getting a chance to access that is very infrequent.

It’s on the list :slight_smile:



sounds quite funny, but after > 10 days, the CEC name is displayed on the Samsung UE55 now. While my tests, I really unplugged the mains from TV for 20 seconds, but the CEC name kept “Kodi”. Next days I did nothing than watch TV, EPG and recorded movies, but no further power off/on. It still was “Kodi”, while the XML had “eva9003” in the named entry.
I stopped the test, because I planned to wait for the proposed hostname==CECname change first.

More than a week later, with every day using the OSMC box, my wife called me “now its not longer named ‘kodi’, is this what you are waiting for?”. After a detailed interrogation, she remembered the TV was magically powered on in the morning. This only happens when the Raspi performs a reboot by updates (or by accidentially mains fuse triggering). And this was finally the only thing I did not in all my tests. I ever performed a reboot on the ssh shell, but never a power cycle…

Just for the records…

Fully powering down Pi and TV at the mains for a few minutes is a common solution to a lot of CEC problems.

Okay, I’m now quite sure to have it:
In the meantime, while maintaining my UPS, I found a log entry about lost mains power in the whole building for aprx.15 minutes in mid of October. This corresponds with the time we experienced the magically appearance of the wanted CEC name in the Samsung TV CEC/Anynet Menu.

Lessons we learned:
Powering an Samsung UE55 for 10 … 20 seconds might no be enough to really reset the cached Anynet/CEC client settings. Must be a very power saving circuitry to hold the data. Or might have a Coldcap capacitor.