Change default Player

How can I change the default Player names PaPlayer to Videoplayer?
Is there any file an on which directory can I find them?

This can be done via XML – why do you wish to do this?

Because when I play music via Spotify or Local Library I only hear music.
No player will be shown. No Player is displayed.
I do not see any fanart, no animations, nothing.
I do not know why.
Only if I go back completely and go next to power button on the player button, I can show the player.

Please help.

Using OSMC Skin, there is an option at GUI->settings->interface->configure skin->OSD->open music fullscreen window when idle during music playback.

Don’t know whether this works with Spotify playback but give it a try and feedback, here.

That is called full screen. You can map a button on your remote to bring that up (assuming you have a button to spare). Changing the player is not going to alter the behavior your describing though.

OK, I’ll have a look. I’m on the road with Estuary Mod Kodi 18. Let’s see if it works.

I will start a trial and report.
Many thanks

OK that’s the right way.

Thx