Change of skin causes major problem

Hi there.

I just updated my Vero 4K to the latest version (cannot tell you number as I will explain).

After the update, I watched a movie file using the mimic skin and it worked fine.

I’m still trying to figure out which skin I like best, so after the movie I looked around and tried installing the first one available. I do not know the name, but the icon was the famous image of man by Leonardo da Vinci

It was applied and now I cannot access settings. Using the remote, I can shift between menu items and even go into tv, movies and music and see my media. However, if I try to go to settings or add-ons, nothing happens. The little swoosh noise happens, but nothing on the screen. I unplugged the device to reboot it and that did nothing.

How do I get away from this skin if I can’t enter settings? If possible, I would rather avoid wiping the whole device clean and have to spend hours setting it up again.

Thank you for your help.

Login via SSH and do
sudo systemctl stop mediacenter
mv .kodi/userdata/guisettings.xml .kodi/userdata/guisettings.xml.backup
sudo systemctl start mediacenter

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

And suggest you change the title to “Change of Skin cause major Problem”

1 Like

Thank you. I revised the title and will attempt the fix tomorrow.

While using SSH to gain access to the box did work, the problem persists, so I am wondering if it is related to the update since it only started then.

Doing as you advised, I was able to reset the skin back to the default OSMC skin. However, the problem persists. The default skin has 2 settings section and only one them works. The first one does nothing, the second goes into settings. The Add-Ons section also does nothing and cannot be accessed. The Movie/Music/TV sections work as they should.

What would be my next course of action?

SSH into the device and provide the URL that results when issuing the grab-logs -A command.

URL is: https://paste.osmc.tv/ximojonoxe

Try this command followed by a reboot.

sudo apt-get install --reinstall mediacenter-skin-osmc

Unfortunately, that had no effect. I still have 2 settings options, only one of which works, and the add-ons section still does nothing.

You can try to active debug logging via command line and upload logs with grab-logs -A to try to find something but maybe a clean up of Kodi configuration might be the easiest after all

I think you may be right. Is there a way of starting fresh by SSHing into the device? I found this article Reinstalling OSMC - Vero 4K - OSMC describing using an SD card. Is this the way to go?

Well there are two “levels” of starting fresh:

  1. Just start with a fresh set of Kodi settings (my recommendation in your case):
    Login via SSH and execute
    sudo systemctl stop mediacenter
    mv .kodi .kodi_backup
    sudo systemctl start mediacenter

  2. Starting with a fresh install for OS (Debian) and MC (Kodi)
    For this you would have to just start clean with a new SD Card installation. And yes for that you would follow Reinstalling OSMC - Vero 4K - OSMC

Thank you fzinken. I tried option 1 and the menu appears normal again. I will have to rebuild the file locations, weather providers, etc, but it’s looking like it’s back on track.

Again, thank you. I shall return should I have further difficulties.

You could try to just copy your previous sources.xml
sudo systemctl stop mediacenter
cp .kodi_backup/userdata/sources.xml .kodi/userdata/
sudo systemctl start mediacenter