Command to Launch OSMC Settings App

On my previous Raspbmc install I used the following code to launch the Raspbmc settings add-on from a custom Home screen sub-menu:


What’s the equivalent command to launch the OSMC settings app? I’ve looked through the debug log and it looks like launching the settings app app calls a service, rather than a script?


I’m not sure how to turn this path/command into a skin <onclick> action. Any ideas?


That should work. The settings module is both a service and a script. The script sends a signal to the service to open the window.


Works perfectly - thanks! I should have just tried that, I assumed it would be something more complicated…

Does anyone know how to run a command to launch just the network window from OSMC Settings App?

I already tried these custom paths without luck:



I dont even know if this is even possible, i just want to have a home button directly to configure the network.


RunScript($INFO[Window.Property(MyOSMC.Module.Script)], script.module.osmcsetting.networking)

1 Like

Im using Mimic skin, I changed this on the “setup the main menu” option using a custom shortcut and adding the path you just gave but unfortunately it didnt result as i thought, any sugestions? By the way, im using a RPI2

Hardware doesnt factor into this. MyOSMC runs the same on every device.

Turn on debugging and try again. Then post the link to the logs here. That should indicate what went wrong.

Info on how to upload logs can be founds here:

So I did it and here’s my log file:

I hope this can be achieve somehow, thanks in advance Karnage!

Any headway? I’m looking to do exactly what you were; run MyOSMC==>Networking from the home screen menu. I cant get any commands to work other than RunAddon(service.osmc.settings).
Am I missing something in how one uses RunScript? When testing commands over SSH, nothing happens with the RunScript example as posted. Can anyone please tell me what I’m doing wrong with the following

`kodi-send --action="RunScript($INFO[Window.Property(MyOSMC.Module.Script)], script.module.osmcsetting.networking)"`

This command no longer works. can you please update this post with a working script that would be awesome Thanks.