Configure buttons on CEC Remote Control


In the last two days I started using CEC Remote Control with my Samsung TV. It works perfectly.
Previously I had an USB IR Sensor with its own remote control. Now I am using the same RC for both TV and Kodi.
That is great.

But I want now do a small improvement. Whenever I start a movie for play, pause, stop, fast forward and rewind actions I use arrows to navigate on Player Controls buttons. It is ok for me doing so but on my Remote control I have few buttons for Player Controls: play, pause, stop, fast forward and rewind. I would like to use them.

Whenever I press Play it palys/pause. It is the only button that works.

So I installed Keymap Editor and tried to configure the buttons. I was able to associate play command to play button and stop command to stop button. That’s all. Pause, fast forward and rewind were not recognized at all.

So I tried to do it manually working on /home/osmc/.kodi/userdata/keymap/gen.xml. I enable debug logging in order to have the key id associated to the button above. With my surprise only stop and play buttons are recognized (I see the id in the log file) for the others buttons nothing happen.

Why? How can I solve the issue?

Hi again,
I just find out that assigning the default keys I basically have all Play Controls shortcuts.

  • play button I can play/pause;
  • with left arrow button (NOT the rewind button) I can rewind;
  • with right arrow button (NOT fast forward button) I can fast forward;
  • stop button I can stop after my configuration.

So from an action point of view I have all the shortcuts on my remote control. It would have been nice if also fast forward, rewind and pause button had worked. But at this point I am ok with this configuration. If someone know why these three buttons are not recognized at all please let me know.