Connecting microsoft foldable keyboard

Hi,

Just bough this microsoft foldable bluetooth keyboard https://www.amazon.co.uk/Microsoft-Universal-Foldable-Bluetooth-Keyboard/dp/B010SPV1OK

when i go to my osmv,network then bluetooth and discovery, it finds the keyboard no problem. then when i click pair without pin, it connects fine and shows up in paired devices.
but i cannot get any part of OSMC to recognise key presses or interact with the keyboard.
the keyboard has 3 source settings, ios, android and windows (which i didn’t realize upon purchasing). i have tried all 3 but to no avail. surely this cant be the reason its not working? if so, please let me know and ill return it.

Cheers

It’s worth exiting to the command line and seeing if you can get it to work there.

Also might need to restart Kodi after pairing (but suspect not).
Is there an explanation of what the three options actually do? I would have thought a keyboard would just behave as a keyboard…

Sam

Still no luck after rebooting. the 3 options for sources will be for connecting to a windows device, ios device or android device. no further mention of why, like you say i would expect a keyboard just to work. and i think it should.
i have no idea about exiting to command line. please elaborate.
Thanks for your help

Ironically you may need a USB keyboard to do this. See https://osmc.tv/wiki/general/accessing-the-command-line/

Try mashing some keys and see if you see anything

Sam