Connection problems

I have a problem with my raspberry OSMC, I can’t use YouTube and update forecast. Obviously I can’t use the App market.

The raspberry has a wired connection, I tried also using wi-fi or setting manually the servers IP and DNS, but the problem did not solve.

But the strange thing is that the software update has gone fine.

Today after update i have this error message: " OSMC Update Error, Error Installing :samba; please report this on the OSMC forum".

What is wrong? If you need more information let me know.

Why not?

Can you explain the issue exactly?

If it’s a lack of connectivity – then check Network settings. What does it show?

Sounds like the updates didn’t go fine, likely due to connectivity issues.

Check the connection to the Pi – do the NIC lights come on?

It seems like there is a lack of connectivity, but the network is properly configured. I tried also to use the Google DNS and but it does not work.

Status: eth0 (connected)
Wait for network…

About Samba, I tried to uninstall and reinstall but I did’t get any positive result.

Can you SSH in?

Do you have an IP address?

You may need to log in via the command line. Instructions are in the Wiki. Then you can run ifconfig and connmanctl to assess the situation

Running ifconfig we obtain:
eth0 Link encap:Ethernet HWaddr b8:27:eb:3e:1f:1c
inet addr: Bcast: Mask:
RX packets:391 errors:0 dropped:0 overruns:0 frame:0
TX packets:505 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:40616 (39.6 KiB) TX bytes:66761 (65.1 KiB)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:415 errors:0 dropped:0 overruns:0 frame:0
TX packets:415 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:34203 (33.4 KiB) TX bytes:34203 (33.4 KiB)

Then I tried

osmc@osmc:~$ connmanctl
Error getting VPN connections: The name net.connman.vpn was not provided by any connmanctl>

… and now?

Looks OK

Can you ping the device?
Can you ping out?
What does route show?

Yes I can ping…and everything it’s ok :confused:

I solved the problem…fomatted and reinstall everything. :grimacing:
Thanks for the support!!!:heart_eyes: