Connection refused via ssh since messing with powerline adapters

Hi everybody, until yesterday, I could access my hdd plugged to osmc using Bitvise SSH on Windows 10.

I now get an error message saying “connection failed: FlowSocketconnector; failed to connect to target error”.

I have read that someone had the same problem, which was due to his Powerline adapters. For me, it looks like it is the same problem as I have moved one of the adapters to another room for test purposes until I plugged it back on my raspberry.

I have tried several things:
1 swap the power adapters
2 pairing the adapters again
3 desactive and reactivate samba server and ssh server services in osmc.

Nothing’s worked.
I would really appreciate any help as I am stuck.
Thank you

Have you for testing tried without the adapter? That would be the first test I would do?

Can you still access the osmc samba share?

Did you do any other changes or updates recently?

Did you also confirm that the IP address has not changed?

ActionA, yes, I confirm the IP address has not changed. As a matter of fact, I have tried using the remote app Yatse, I think it uses the IP address and the app is still working.


  • I will try without the adapter. I have the “old” raspberry, so wireless is not included but I might have a wifi adapter USB somewhere. I’ll give it a try.

  • I did not do any update, just messing with the adapters.

  • How do you access the osmc samba share? Via web browser using the IP address?

And can you ping the Pi?

Why so complicated? Just for temporary testing carry the pi to the start point of your powerline setup

I am wondering why you installed the samba server if you even don’t know how you access it? Depending on which OS you use it is slightly different but normally something like network neighbourhood or browse for server

Yes :slight_smile: why didn’t I think of that? Thanks

I am wondering why you installed the samba server if you even don’t know how you access it?

Well, the thing is, I just don’t know whether my access from Windows to the raspberry via ssh is run by the samba server app or ssh server. In doubt, I didn’t want to touch any of those. After all, it was working so far so why fix it?

Anyway, I’ll connect the rasbp straight on the router, then on the first adapter like you suggested.
If it works, I’ll assume the problem comes from the adapters.

Then, I would desinstall samba server and ssh server, and reinstall ssh server.
To be honest, I don’t know anything about ssh, I just assume it’s the right course of action.
What do you think?

Thanks everybody.
While I was answering jb2cool, I tried and connect again and would you believe it? For some unknown reason, the connection from windows to my rasp is working again.

Thank you for your help, guys.

Well the question is the right course for what? If someone would ask me is walking southwards the right course to the north pole I might answer yes because it’s the longer way but it’s still the right course.

SSH client/server is the right combination to get access to the command line of OSMC.

Samba client/server is the right combination to transfer files from/to OSMC.