Connection ssh failed, wrong password

Hello everybody,

My password for ssh has changes without an action of my part… I cannot connect on my OSMC in ssh. My password was registered in keepass, so impossible to be wrong.

Is there a solution to pass through the problem without re-install all the OSMC. I’ve got too many automatic script that are only on the raspberry…

Thanks for all of your answers :slight_smile:

I find it. Here’s how
1 - mount sdcard on linux
2 - launch the comand md5pass [my_password]
3 - note the hashed paswword
3 - edit the file file /media/[user]/[ID-device]/etc/shadow
4 - replace the line
5 - save the file
6 - umount sdcard

That works !

Glad you sorted it, I’m wondering if something has changed today as I’m getting an incorrect password error on 2 remote devices (my parents and grandparents) that I’ve not copied the ssh-key to yet so I won’t be able ot access until I go and visit them.

Any chance you could run:

cat /var/log/apt/history.log

Then paste the output into the osmc paste bin:


Well if you have not changed it someone else has so suggest you:

  1. Check how someone could have changed the password! Have you port forwarding from the Internet enabled? Did you change the default password? Any repositories installed which might have gained access to the system?

  2. As your system my have been compromised and someone might have installed a backdoor suggestion is to start with a clean install