Crash and reboot after august update

Hello,
The update doesn’t work.
Osmc always reboots,and the bad smiley appears after each reboots.
I have a raspberry pi 3.
What I am doing now?
Thanks for your help

Well two options either provide debug logs as explained in the other thread or a quick and dirty solution.
Log in via command line and execute
mv .kodi .kodi_backup

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

Same thing for me.

I answered “yes” to the question “do you want to update” (as every month for years), and now it restarts again and again.

kodi.log contains the following:

20:31:06.832 T:1959014400 NOTICE: Starting Kodi (17.4). Platform: Linux ARM (Thumb) 32-bit
20:31:06.832 T:1959014400 NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)
20:31:06.832 T:1959014400 NOTICE: Kodi compiled Aug 27 2017 by GCC 4.9.2 for Linux ARM (Thumb) 32-bit version 3.16.39 (200743)
20:31:06.833 T:1959014400 NOTICE: Running on Open Source Media Center 2017.08-1, kernel: Linux ARM 32-bit version 4.9.29-9-osmc
[…]
20:31:07.388 T:1959014400 NOTICE: Running database version Addons27
20:31:07.706 T:1959014400 FATAL: addon ‘kodi.inputstream’ not installed or not enabled.
20:31:07.707 T:1959014400 FATAL: CServiceManager::Init: Unable to start CAddonMgr

I was unable to figure how to fix it.

I tried to remove guisettings,xml to reset them (including returning to the confluence skin), but it had no effect.

I also moved the .kodi dir, a fresh one was recreated but the effect is still here.

I have another installation, where it upgraded perfectly well and is running, but there are slight differences (different skin, no CEC,…).

I would prefer fixing the problem rather than reflashing the SD card.

Please help !

Best regards,
Ch. Tronche

Try following @fzinken’s advice above.

Isn’t it what I did ? Moving kodi and providing the log content ?

Best regards,

Provide a complete set of logs taken after you have removed the .kodi directory. Your snippet does not reveal the root of the cause.

grab-logs -A

Here we are
https://paste.osmc.tv/fagabugira

Best regards,
Ch. Tronche

Your dist-upgrade already throws an error since April, not the best sign

Error: Sub-process /usr/bin/dpkg returned an error code (1) End-Date: 2017-04-01 23:28:13

My guess is some issues with the filesystem, you can try the following commands:
sudo apt-get update sudo apt-get dist-upgrade sudo apt-get autoremove sudo apt-get remove rbp2-mediacenter-osmc sudo apt-get install rbp2-mediacenter-osmc

It worked after reinstallation, as you advised.

For some reason, rp2-device-osmc couldn’t be removed with apt-get, I changed the status by editing /var/lib/dpkg/status.

After removing / reinstallation of both rbp2-mediacenter-osmc and rbp2-device-osmc, everything worked as expected.

I’ll perform an fsck at some point to see (I can’t right now, because one of my kids is watching cartoons, best proof that it’s working).

Thank you very much to all !

Best regards.

It’s an essential package; and doing this will break things.

I suspect you will run in to problems in the future until the root cause is determined