Crash when play video

Hi everyone,

First of all, I’m new in your community, so feel free to call me to order if I break some of your rules.

I recently bought a Rapsberry Pi 3 and I decided to install OSMC on it to have my own media center.
It is currently plugged to my TV screen with HDMI cable and has access to my home network thanks to an RJ45 wire connected to my internet box (which actualy works as a router).
All seems good, I can access to my Rapsberry with SSH, I can control OSMC with my smartphone using Kore v2.0.0, I can reach my files stored on my NAS.
BUT, (yes there is a but) when I try to play any video, it systematically crashes with a sad smiley displayed :frowning:

I tryed with small video files (few MB) and in that case it worked. I can also view photos or play music. But nothing to do with films.

An important point is that the Raspberry is powered up with a 5V/2.1A transfomer. I know it’s recommanded to use a 5V/3A transformer but I haven’t one.
Could power supply be the cause of these troubles ?
Another thing, I used a 4GB SD card, is it enough ?

Thanks, have a good day !

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see How to submit a useful support request - General - OSMC for advice on how to help us.

4gb is about the smallest that a fresh, clean install will fit on, but functionally, it won’t last long before cover art and other metadata have filled the entire space. 8gb would be the min recommended sdcard size.

Do you see a warning square in top right of display?
What does “vcgencmd get_throttled” (over ssh) report after a sad face?
As @ActionA says, the logs would be useful.

Hi, no warning square on the top right display. Moreover, the SSH connection isn’t broken : this suggests the problem is not the power supply. Do you agree ?

When I run the command vcgencmd get_throttled after a sad face I get : throttled=0x0

[EDIT] Here are my logs :
I also tryed to store an MP4 (1MB) sample video directly on the Raspberry and to play it but I got the same result :frowning:


First remove the overclock

arm_freq=1000 core_freq=500 over_voltage=2 sdram_freq=500

Note: if this is a Pi3 you are actually underclocking the arm and overclocking the GPU/sdram.

Oh yes, I tryed this to see if it could change something but OSMC was already crashing before overclocking.

Can you upload the 1MB video file (e.g. to dropbox or google drive) and I’ll test it.
I’d like to know if I have the issue with it.

Here are the sample video files :

Hi, I installed MediaInfo to see informations about video codec used …etc
It looks like OSMC always cashes with video encoded with H.264 codec.
Codec Indeo 4 can be read but with sound shift.
Code YUV is read without problem : I only tried with a 6sec video (~28MB).
Code MS Video is read without problem : I only tried with a 44sec video (~156MB).

I am the only one having this issue ?

Upload the MediaInfo output

Here are de MadiaInfo details :

First video:

Second video:

Last one:

The last one is played without sound.

Note that videos were recorded with smartphone and digital camera.


Select ‘Text’ so we can see all the information pleease.

Those mediainfo output seems not to be fitting the links you posted above

Can give a single URL for one file that gives you problems and also provide the mediainfo in text form for that.
You can install and use mediainfo on OSMC for that.

Yes, they’re not. I posted video informations that can be read by OSMC.

Video 1

Complete name : Z:\test\test1.AVI
Format : AVI
Format/Info : Audio Video Interleave
File size : 27.9 MiB
Duration : 9s 400ms
Overall bit rate : 24.9 Mbps

ID : 0
Format : YUV
Codec ID : IYUV
Codec ID/Info : Intel Indeo iYUV 4:2:0
Duration : 9s 400ms
Bit rate : 23.0 Mbps
Width : 320 pixels
Height : 240 pixels
Display aspect ratio : 4:3
Frame rate : 25.000 fps
Color space : YUV
Compression mode : Lossless
Bits/(Pixel*Frame) : 12.000
Stream size : 25.8 MiB (93%)

ID : 1
Format : PCM
Format settings, Endianness : Little
Format settings, Sign : Signed
Codec ID : 1
Duration : 9s 400ms
Bit rate mode : Constant
Bit rate : 1 536 Kbps
Channel(s) : 2 channels
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Stream size : 1.72 MiB (6%)
Alignment : Aligned on interleaves
Interleave, duration : 40 ms (1.00 video frame)

Video 2

Complete name : Z:\test\test2.avi
Format : AVI
Format/Info : Audio Video Interleave
File size : 157 MiB
Duration : 44s 0ms
Overall bit rate : 29.9 Mbps

ID : 0
Format : MS Video
Codec ID : CRAM
Codec ID/Info : Microsoft Video 1
Duration : 44s 0ms
Bit rate : 29.9 Mbps
Width : 1 280 pixels
Height : 1 024 pixels
Display aspect ratio : 5:4
Frame rate : 50.000 fps
Bits/(Pixel*Frame) : 0.456
Stream size : 157 MiB (100%)

Video 3

Complete name : Z:\test\test3.AVI
Format : AVI
Format/Info : Audio Video Interleave
File size : 30,7 Mio
Duration : 6s 573ms
Overall bit rate : 39,2 Mb/s

ID : 0
Format : Indeo 4
Codec ID : IV50
Codec ID/Info : Intel Indeo Video 5.0 Wavelet
Duration : 6s 573ms
Bit rate : 37,3 Mb/s
Width : 1 280 pixels
Height : 720 pixels
Display aspect ratio : 16/9
Frame rate : 29,970 Im/s
Bits/(Pixel*Frame) : 1.352
Stream size : 29,3 Mio (95%)

ID : 1
Format : PCM
Format settings, Endianness : Little
Format settings, Sign : Signed
Codec ID : 1
Duration : 6s 573ms
Bit rate mode : Constant
Bit rate : 1 536 Kbps
Channel(s) : 2 canaux
Sampling rate : 48,0 KHz
Bit depth : 16 bits
Stream size : 1,20 Mio (4%)
Alignment : Alignée sur les interleaves
Interleave, duration : 33 ms (1,00 image vidéo)

For me these play fine:

This one doesn’t play:

It does play if you disable hw video decode.

Hy everyone, I finaly fixed my problem.
It was the audio DSP treatment which made OSMC crash.
I disabled it and it simply works :slight_smile:

Which DSP settings did you have enabled to induce this crash?

Can you replicate the crash with DSP on and post the debug log here?

This will help improve things.

I bought a Pi 3 today and installed OSMC and had exactly the same issue.

The issue was when the “enable audio DSP processing” was enabled.

No issues with it disabled.

I havent tried to do a log yet, but ill learn how and post later.

DSP is disabled via default. It’s best not to enable it now as it’s broken

Is there any plans in osmc roadmap to improve / stabilize audio dsp ?
(it still craches osmc with some movies, and it would be nice to have some config options to fiddle with :slight_smile: )