Crashes when playing video files

Hi all, I have installed Emby which is set up to link to my Emby server which is on my NAS. However, when syncing after installing latest version of OSMC it keeps crashing eventually it loaded my TV Shows and Movies.

Next issue is when trying to play back any video file it may play for a few seconds then crash and get sad face error, or it might freeze and not play.

I have tried playing different files MKV MP4 etc some 720p 1080p and a couple of 4k they all do the same.

I have tried playing a 1080p video from USB and it does the same.

I can play the files find via emby on my phone and PC, I can also play the files fine via the Emby app for my TV(this isnt the ideal way of me doing it though).

Ive had this Vero 4k for a few months and never have had this working yet.

Here are the logs from crashing during playback via Vero 4k

Here os the logs after crashing from playback via USB

Thanks for the help.

Thanks for the logs.

Can you update your system and see if you still experience issues?



Update applied.

Tried to play a movie again get sad face error here is the logs

Thanks for the help!

This doesn’t look like a debug enabled log.
Also (while I doubt it is related to your problem seems there is a time dfference between you emby server and the Vero4k

Thanks I will take a look at that.


I have managed to watch a 1080p movie without crash however on pressing back on my remote to go back to main menu I get sad face error again the log is .

I then tried to watch a different 4k movie than before and it crashed again after a few seconds .

I forgot to mention that its now the latest version see my reply above for logs and details.

@sam_nazarko Any ideas Sam?

Something is causing Kodi to segfault, ie crash. Since you had the problem before and after the latest update, it’s probably not the kodi.bin executable that’s crashing, though any one of the libraries that it links to could have become corrupted.

I see that you already tried to play from a locally attached drive, but please check once more on the latest version.

If that doesn’t work, please run the following from the command line:

cd ~
sudo systemctl stop mediacenter
mv .kodi kodi_bak
sudo systemctl start mediacenter

and see if the problem is still there with a locally-attached dirive. If it works, install the Emby add-on and try with that.

Update: Sorry, I missed this:

From your (second) log in post #6:

Linux osmc 3.14.29-61-osmc #1 SMP Mon Mar 5 12:38:26 UTC 2018 aarch64 GNU/Linux

The Vero4K is now on kernel 3.14.29-69. You should update to the latest version.