De-interlacing issue, Inspector Morse DVD rip

I’ve tried this via white listing 576p as well as not white listing. But I get some serious jaggies. If I whitelist, is it the tv doing the deinterlacing?

Here’s the mediainfo for the video:

ID                                       : 1
Format                                   : MPEG Video
Format version                           : Version 2
Format profile                           : Main@Main
Format settings                          : BVOP
Format settings, BVOP                    : Yes
Format settings, Matrix                  : Default
Format settings, GOP                     : M=3, N=13
Format settings, picture structure       : Frame
Codec ID                                 : V_MPEG2
Codec ID/Info                            : MPEG 1 or 2 Video
Duration                                 : 1 h 43 min
Bit rate mode                            : Variable
Bit rate                                 : 5 151 kb/s
Maximum bit rate                         : 9 500 kb/s
Width                                    : 720 pixels
Height                                   : 576 pixels
Display aspect ratio                     : 4:3
Frame rate mode                          : Constant
Frame rate                               : 25.000 FPS
Standard                                 : PAL
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Interlaced
Scan order                               : Top Field First
Compression mode                         : Lossy
Bits/(Pixel*Frame)                       : 0.497
Time code of first frame                 : 09:59:59:00
Time code source                         : Group of pictures header
GOP, Open/Closed                         : Open
Stream size                              : 3.74 GiB (94%)
Language                                 : English
Default                                  : Yes
Forced                                   : No
Color primaries                          : BT.601 PAL
Transfer characteristics                 : BT.470 System B/G
Matrix coefficients                      : BT.470 System B/G

Any ideas?

Can you upload a log so we can see your settings?

Also, can you see if it’s fixed in the next update. To do so:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Kodi is not able to pass through an interlaced source. Even if you set your display to interlaced Kodi will deinterlace, and then reinterlace it on its way out. The whitelist affects resolution and frame rate only.

When you are playing a video you can press the select button to bring up the OSD, click on the gear icon, and inside of the video settings menu you can change what deinterlace method is being used.

That only works if you’ve disabled hardware acceleration, doesn’t it?

Mind you, disabling hardware acceleration may well be useful in this situation: software-mode deinterlacing in Kodi is quite good.

I think that icon is a reel of film, btw. :slight_smile:

I don’t know the answer to that question but CPU decode of a SD MPEG 2 should be pretty easy for the Vero to handle.

In the OSMC skin it is. It is a “settings” menu which most other skins designate by the standardized gear icon. The film reel is a bit of a bold choice that I hadn’t noticed before. :grin:

So I’ll try the update later @sam_nazarko but it’s definitely the Scan Type: Interlaced.

Currently have 576p whitelisted and hardware decoding set to HD and up only.

Only deinterlace options available are Off; Deinterlace (Half) and Deinterlace. None make any difference.

Currently watching American Dad which is Scan Type: Progressive and it’s perfect.

Here’s an example of how bad it is.

@sam_nazarko will get dumps later but the update I just received made no difference.

Indeed – we haven’t made any changes to improve anything in this area as we need more information from you


I navigated to an affected video, let it play to some content that isn’t deinterlacing properly and then uploaded :+1:

@sam_nazarko or anyone, any thoughts/updates?

Not sure how I missed this. Will check it shortly


Thanks Sam!

Anything @sam_nazarko ?

Sorry for the delays here.

I’ve had a look and can’t see an obvious reason why this isn’t being deinterlaced. Did it only occur recently? If so - it may be an issue introduced by updating ffmpeg in Kodi

Does playing with hardware acceleration disabled resolve the issue?

Thanks for the reply Sam. Hardware makes no difference not does in whitelisting 576p.

It’s definitely that scan type I mentioned earlier in the mkv meta data that is the issue. If it’s progressive all is good as expected.

It could be Kodi/ffmpeg. I’ll also do some hunting on the Kodi forums.

Can you send me a sample of this file?

Alternatively I can record an upcoming episode and see if it has a problem.

Hi Sam, it’s the DVDs. I don’t use live TV. An episode of That Mitchel and Webb Look is what shows it the best, the screenshot from an earlier post is from that episode.

At work currently but let me know what’s the best way to get it to you and I can cut up the mkv.

If you can cut a file to <500MB and still reproduce the issue I can send an upload link


Thanks Sam, I’ll sort something out later this evening :+1: