December update freezes at Reached target RPC Port Mapper

After December update my osmc boots to Reached target RPC Port Mapper and then freezes. Tried restarting RPC Port Mapper and reenabling RPC Port Mapper but still freezes at same point. Everything worked fine prior to update. Know that RPC Port Mapper is running.

Thanks for help


Please have a search for dtoverlay=mmc. If this resolves it, please note the make and model of your card.

Tried that before I posted. Should have noted that. Working with a RaspberryPi B+, Samsung sd card.

When did you upgrade? Make sure that mmc-overlay.dtb is in your overlays/ directory.


Downloaded and placed mmc-overlay.dtb in overlay folder and rebooted. Still stops as RPC port mapper

Did you also added dtoverlay=mmc to your /boot/config.txt?

yes/ Did that before I posted.

Does it boot far enough that you can log in via SSH ? If so please provide the output of:

grab-logs -A

Thanks. Did that and got
Logs successfully uploaded.
Logs available at http:://“message”:"Documentexceesmaximumlenght.

Concluded it was time to upgrade to a RaspberryPi 2B, which I purchased and will now set up with a fresh install.