[Deprecated] [TESTING] Bluetooth audio streaming (A2DP)

Hi

Can you go into plugins-> my plugins -> service plugins and check that BTPlayer is enabled

I can’t see the plugin loading in your logs and this is possibly why you are not seeing info from streaming

Are you using the official OSMC dongle? No additional firmware should be needed for this.

If not, what does dmesg show?

Indeed BTPlayer was not enabled.
Issue solved. All works now.
Sorry for this noob issue.
I wasn’t aware that is should be enabled separately.

Thanks for your support!

Thanks for letting me know you have it working

Its not a noob issue something I have missed I will make sure it gets automatically in a future release not sure if it will make the rc1 build tho

No it’s not the official OSMC dongle.
It’s a HAMA usb-adapter class 2

[    0.354256] usbcore: registered new interface driver usbfs
[    0.354383] usbcore: registered new interface driver hub
[    0.354548] usbcore: registered new device driver usb
[    1.731992] usbcore: registered new interface driver smsc95xx
[    2.133848] dwc_otg 3f980000.usb: DWC OTG Controller
[    2.133909] dwc_otg 3f980000.usb: new USB bus registered, assigned bus number 1
[    2.133963] dwc_otg 3f980000.usb: irq 62, io mem 0x00000000
[    2.134348] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    2.134368] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    2.134385] usb usb1: Product: DWC OTG Controller
[    2.134401] usb usb1: Manufacturer: Linux 4.4.27-5-osmc dwc_otg_hcd
[    2.134416] usb usb1: SerialNumber: 3f980000.usb
[    2.137022] usbcore: registered new interface driver usb-storage
[    2.138197] usbcore: registered new interface driver usbtouchscreen
[    2.218419] usbcore: registered new interface driver usbhid
[    2.218428] usbhid: USB HID core driver
[    2.507305] usb 1-1: new high-speed USB device number 2 using dwc_otg
[    2.707631] usb 1-1: New USB device found, idVendor=0424, idProduct=9514
[    2.707656] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    2.987327] usb 1-1.1: new high-speed USB device number 3 using dwc_otg
[    3.087654] usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
[    3.087683] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    3.150482] smsc95xx 1-1.1:1.0 eth0: register 'smsc95xx' at usb-3f980000.usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:f3:e3:bc
[    3.397275] usb 1-1.4: new full-speed USB device number 4 using dwc_otg
[    3.582684] usb 1-1.4: New USB device found, idVendor=0a12, idProduct=0001
[    3.582712] usb 1-1.4: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[    3.582724] usb 1-1.4: Product: CSR8510 A10
[    6.231951] usbcore: registered new interface driver btusb

Where can I find this setting?

I’m having connection issues. Pairing works, but connection fails.

“Dec 30 13:05:29 osmc bluetoothd[582]: a2dp-source profile connect failed for FC:3F:7C:C2:E2:B3: Protocol not available”
Complete log: http://paste.osmc.io/gujezaviba
Tried two different Bluetooth dongles, no official ones.
Did an apt-get install bluez-firmware, still same issue.

On my phone I can only share contact info with the osmc Bluetooth device it’s paired with. With my Bluetooth speaker I also have the option to enable phone audio and media audio with that Bluetooth device

It looks like you have not installed the a2dp-app-osmc package

Can you run from an ssh session:

sudo apt-get install -f a2dp-app-osmc

This should install version 1.0.7 of the a2dp-app-osmc package and the required PulseAudio dependencies

Reboot then you should be able to pair your phone

You will also need to enable the BTPlayer service

Go into plugins-> my plugins -> service plugins and check that BTPlayer is enabled

Thanks! I got it to work. BTPlayer option is under add-ons, so couldn’t find it at first.
Streaming audio from phone works. Stutters sometimes, but overall it seems to work pretty good :+1:.

Sorry yeah I should have said addons rather than plugins

The player launches for me and I am able to pair, but no artist info is displayed. I can provide a log if needed! Gotta say this is amazing work so far! I use osmc for my RPI touchscreen in my car and I can’t tell you how long I’ve been waiting for something like this!!!

Would you be able to provide debug log please see How to submit a useful support request - General - OSMC

What is displayed where you would expect the track and artist info (in full screen view) ?

Log info is here. http://paste.osmc.io/zasifilopo
It displays a blue/black screen and it says track/2

What device are you streaming from?

Oh sorry! I am using a raspberry pi 3 and I’m streaming from my phone. (Samsung Galaxy S5)

Are you using the internal Bluetooth adapter on the Pi 3?

Can you disable it and try using an external adapter?

I have an external adapter. Is the best way to disable it to modify the blacklist.conf?

I’ve been trying to pair two devices (Jabra Sport Pace Wireless & Sony MDR-10RBT) for a few days, without success so far:
I have tried using pair with & without PIN. It either fails to pair, or systematically fails to connect once paired.
I have tried with the RPi3 internal chipset, and with the official OSMC BT dongle after adding dtoverlay=pi3-disable-bt in config.txt and rebooting.

Any idea ? Thanks and happy new year!

I disabled Bluetooth by running sudo systemctl disable brcm43xx.service and adding dtoverlay=pi3-disable-bt in config.txt. The audio still goes through the pi but now the fullscreen visualizer no longer appears. I’m using an external Bluetooth adapter (IO Gear bluetooth 4.0 Model GBU521)

Update: It seems to perfer to be connected (via bluetooth) through the pi rather then pairing on my phone. The first song I select shows artist info (no album art) but when I change track the screen goes blank again

Hi

Can you provide logs when you have this issue please?

AlbumArt is not supported via A2DP,

Ok, this is slowly but surely driving me mad.

So, I’m trying to get BT audio from my phone to OSMC for the best part of 3 days. I have a RPi3 and a bunch of old BT dongles, none of which I’m sure are compatible, but I’ve tried them all anyway + the built-in BT (which I know is problematic, but still I had to try). The result it always the same. I can discover, pair and connect and my phone thinks it’s sending the audio to OSMC just fine. I can see the track info (with varying success and delay depending on which BT adapter I try), but NEVER did I hear a single peep coming from the speakers. I’ve tried everything I could find in this thread. Amixer shows all volumes at 100%. Tried all the different /boot/config.txt option mentioned here and still no success. I would imagine that with at least one of the BT adapters I should have had audio, any audio, stuttering or not.

Any help would be much appreciated. Thanks