Disable auto update via console (ssh)


can someone please tell me the how to disable the automatic update via the console (ssh)?
Device has no internet connection and I can’t access it via remote.

Thank you very much!

If it has no internet connection it won’t be able to update itself

That’s why I want to disable it, since it displays the “OSMC Update Error” Message after trying with autoupdate.

I’d need to disable the updater or remove the auto-update from the schedule list.
Does anyone know how to accomplish that?

Normally – this is configured via My OSMC -> Updates.

I don’t think we have a file to manually disable updates via CLI anymore. You’d need to manually edit the settings under ~/.kodi/addon_data.

Edit file ~/.kodi/userdata/addon_data/script.module.osmcsetting.updates/settings.xml

<setting id="check_freq" value="0" />

which equates to “never check for updates”.

Thank you very much, I checked the file. There was already a “0” in the mentioned line. Is there another place to look, since it tried the update and showed the “OSMC Update Error”-Screen.

Maybe a start up check or a schedule table some place else?

I’ll need to see if I can find anything else on the system that might be running an update. That will require access to my TV, so I’ll need to check this evening.

I couldn’t find anything, so I set my Vero4K to never check for updates and pulled the network cable. It’s usually set to check each day early in the morning. This morning there was no message on the TV.

You haven’t said if there’s any kind of pattern to these error messages appearing but I see you said:

So how do you remove the error message from the screen if you can’t access it with a remote?

I use the ssh console to send the following commands:

xbmc-send --action="stop"
xbmc-send --action="Playlist.Clear"
xbmc-send --action="PlayMedia("path")"

The error msg than disappears. I dunno when it will return, I have not yet found a pattern.
If you have another idea on where to look, I’d check that.

Thank you.

I’m out of ideas. If it happens again, I’d recommend you post logs. In your case, you’d either save them to /boot (-C option) and scp them across to your PC or send the output to stdout (-P option) and redirect the output to a file. Then paste to https://paste.osmc.tv, via whatever method you’re currently accessing the Internet.

If you haven’t already done so, you might also want to try out the Chorus2 Web interface, since it gives you remote-like control from your keyboard. If port 80 doesn’t work, try port 8080.