Disable TV Wake Up on OSMC Boot


I am running the current version of OSMC on a Raspberry Pi 3. Whenever the Pi resets, my Samsung TV wakes up and switches to the HTML port connected to the Pi.

I need to be able to reboot via SSH or via a VNC connection without turning the TV on. The Samsung TV seems to have no facility to disable CEC commands.

Thanks in advance.


I set Settings>system>input>peripherals>cec to “disabled”. The TV still comes on as the Pi is powered up.

The TV wakes up almost immediately on powering up the Pi (well before the OSMC splash screen) so I’m thinking the problem is not within Kodi.

1 Like

I have a similar problems whit my LG… i have also disabled all this feature on CEC config on my TV and i have disabled the auto swith-on but i can’t disable the autoswitch to hdmi port. If i disable it from osmc setting the cec it’s not working at first boot…

With LG you should be able to disable the hdmi source switch in the tvs options. (SimpLink)

I have also set “System/My OSMC/Pi Config/hdmi_ignore_cec”. I have confirmed that /boot/config.txt contains the line “hdmi_ignore_cec=1”

The Samsung TV continues to wake up and switch the the Pi’s HDMI source every time the Pi restarts.

This would seem to indicate the issue is with the TV acting upon sensing that the pi is active, not the pi or OSMC requesting any action.

Then it doesn’t sound a CEC issue. I assume you get this behaviour by ssh-ing in and running “sudo reboot” rather than using a remote control (which could have other effects)?

Possibly the TV is purely detecting the HDMI signal being driven.
Can you add “hdmi_blanking=2” to config.txt. That should boot with no signal on HDMI - I’d be interested if that stopped the behaviour.

Note: booting with display blanked means you won’t see anything on display. But if it makes a difference it should be possible to unblank it.

popcornmix: Yes, this first showed up when I did a “sudo reboot” from an SSH shell.

Based on several of the comments above, I had another look through the Samsung TV menus. I was able to find a setting that causes the TV to ignore CEC commands. From the Samsung TV remote:

Menu/Input/Anynet+ (HDMI-CEC)/Anynet+ (HDMI-CEC)/Off

Thanks to everyone here for your help and advice.

mmmmmmm… on simplink option i have only the option for switch on… not for change source :frowning:

hi I’ve got a somewhat similar question.

I am trying to prevent the TV from waking up with Kodi while maintaining the HDMI CEC functionality to control OSMC via my TV’s remote.

it is a samsung TV and osmc is running on an RPI3 b+

The problem is that if I deactivate the option that Kodi should register as an active source upon start in the CEC Adapter options then the TV does indeed refrain from waking up. However, I lose the CEC functionality altogether if I turn on the TV manually later. I tried messing around with the other options as well but to no avail :frowning:

i guess what i need is an option to have Kodi send the “hello” signal to the TV only as soon as the TV is turned on and not as soon as Kodi boots up

You should try this


thank you for the quick reply. unfortunately that didn’t work either. as soon as i deactivate the CEC-setting to send the signal “active source” i have to do the “handshake” manually via the TV’s menu (anynet or whatever samsung calls it) or there is no CEC functionality