Disk image not downloading

Hi, I’ trying to download OSMC for Raspberry Pi. Whether I use the
installer or try to directly download the image file at http://download.osmc.tv/installers/diskimages/OSMC_TGT_rbp1_20150331.img.gz , it stalls part way through.
Never at the same point. Ranges from 10% to 27%.
I have tried turning of McAfee real-time scanning which didn’t help. Any suggestions?

I’ve just downloaded the image you linked to with no bother.
Possibly you’re hitting it at a busy time (could be congestion on your bband, or too much server activity…)
Without more info, can only suggest you try at different times.
It probably has nothing to do with mcafee ('tho I hate that product - has cost me hours in sorting friends out)

Thanks Derek,
I appreciate the advice. I just tried the installer again. It was going along nicely at 430 kB/s until it suddenly stopped at 14%.
So I tried the image file link again - 454 kB/s until it got to 23.0 MB, then stopped. I think there must be something else going on, particularly if you are able to download it so its not a problem with the mirror site.

Ok it finally worked for me. 19th time lucky. Didn’t do a single thing differently so must just have been a congestion problem as you suggested.
Thanks again.

I had that problem quite often on my laptop (not related to OSMC).

What I did was using wget with the --continue argument. When the download stops for any reason, you can continue where it stopped and dont have to start from the beginning.

Edit: Another possibility for the OSMC-Team might be to provide a torrent-file. This could ease the server load.