Distorted sound after rebooting

#1

For some time now every time I reboot until I play a video file the audio is really loud and distorted. This is even while navigating the GUI. Once I start playing LiveTV or a video file the audio returns to normal until the next time I reboot. Not that I reboot all that frequently, but it’s still worrying as I feel something is wrong.

Debug logs are here
Thanks :slightly_smiling_face:

#2

Does disabling passthrough help?

#3

Just a comment to your video player config: Is there a reason why you have chosen to disable adjust refresh rate instead of having it to start/stop? You find it at GUI->Settings->Player->Videos.

#4

I’ll test that and report back

#5

No I don’t think that was a deliberate decision. May have been something I adjusted by mistake. Do you mind my asking what impact will that setting have? Will it be an obvious visual difference to me? Or more of a behind the scenes?

#6

Unfortunately disabling passthrough doesn’t change anything. Still get the sound distortions until I play a video and then it goes back to normal.

#7

It does not have an effect on your issue. An explanation you’ll find here in the chapter “2 Playback”.

1 Like
#8

Thanks for the link to that and for drawing my attention to this.
I definitely want that enabled and I’m all in favour of improvements even if they aren’t related to the particular issue I’m experiencing :slightly_smiling_face:.

#9

I tried to reproduce the issue with my Panansonic Plasma TX-P42GTW60 (year 2013) and your settings … but I can’t. Although I have a later Panasonic model it is not able to play AC-3.
Your Panasonic is year 2008 and also tells that it is only capable to play 2-channel PCM … but you configured AC-3 passthrough and transcoding???

Other ideas:

  • I’m on the current development branch
  • cable?
  • TV specific issue?
1 Like
#10

Apologies, I forgot to mention that I’m outputting audio straight from my Vero4k to my Sonos playbar via an optical toslink cable; hence why I have passthrough and AC-3 transcoding enabled.

You’re correct in that my tv wouldn’t be able to play that.

#14

Thanks for your response and thoughts as to what might be the problem :slightly_smiling_face: .

I don’t think differences in branches/revisions have caused this (but I could be wrong) as I was on the latest mainline revision until late last week and then updated to the staging branch to take advantage of some improvements to LiveTV. The issue was happening both before and after I updated.

It could be cable related, but in my mind it doesn’t seem too likely as I have no issues with audio at any other time except immediately after I reboot. And then as soon as I play a video/LiveTV it always resolves itself.

I don’t think it’s TV related as I mentioned above the audio is bypassing my TV altogether.

#15

ok, did some things to try to reproduce this

  • laid an optical cable between my Vero4k and my SONY AVR
  • laid an additional hdmi cable between the Vero4k and my Panasonic TV
  • re-assigned the AVR’s optical input to a free HDMI port
  • reconfigured the Vero4k using your audio settings

Booted the OSMC device several times: No distorted sound. Playing movies gave Dolby Digital sound as expected:

Logical conlusion for me:

  • it is not a general issue with all AVRs
  • seems to be very specific to your environment (cable? Sonos playbar?)

Would be good to get the experience of another Sonos playbar user with that optical configuration to see whether this is a Sonos or cable issue.

2 Likes
#16

Thanks @JimKnopf! I appreciate the effort you’ve gone to with testing things on your end.

I’ll do some testing on my end with cables and the playbar and report back.

Thanks,
Ed

#17

Hi,

I have the same problem. Normally my Vero4k+ runs 24/7, so I don’t really care about this bug.

The TV is connected via HDMI, additionally I have a direct connection via optical cable to my av receiver.

1 Like
#18

What brand+model is your AVR?