Dns not working as expected in september update

I Use a dns service (adfreetime) to access US content in crunchyroll (I am in europe). Since the september update this doesn’t work in osmc (it still does on all my other devices in the house).
I reverted to the august update and now everything is fine again.

The dns server is configured in my router and is the same for all my devices, so that is not the problem.
It looks like in the september update you have configured another dns server (which I can’t seem to locate in the system files as i am no good with linux) which impaires the functionality of my dns service.

I’ll just keep using the august update for now but would appreciate if you could fix this.

What does your /etc/resolv.conf file look like ?

Unfortunately without any logs, we can’t.

Unless you have enabled DNS proxying, this shouldn’t be the case.

It has my default gateway listed and the 2 dns adresses porivided by dhcp.
No unknown adresses.
I also tried disabling dhcp through the osmc settings and seting up my connection manually using a third dns server the dns service provides. There was no change. (this address also works on my phone and tablet and tv).

All this is on a raspberry pi 2.

What logs would you need? the kodi log?

OSMC will only populate /etc/resolv.conf with DNS servers it obtains from DHCP unless you specify otherwise in ConnMan’s settings.

To expected behaviour or /etc/resolv.conf?

Try enabling DHCP and then running:

sudo -s
systemctl connman restart

Now, check /etc/resolv.conf. Those are the nameservers obtained via DHCP. Your desired nameserver should be in the list and on the top.

If that is still not working, you will need to use nslookup to check which DNS server is being used and if it’s returning the resolution you would expect.


I have reproduced the problem you describe - connman appears to be writing nameservers in reverse order in resolv.conf, and due to the resolv.conf limit of 3 name servers, if you have 4 servers the primary DNS server is left out altogether thanks to the reverse ordering.

The networking GUI appears to show the correct order. (verified against the order the server is assigning in my test)

As a test, can you try configuring dnsproxy=yes in /etc/connman.prefs (then reboot) and see whether your DNS service works ? Resolv.conf will now show only as connman will use a built in DNS forwarder, but it would be interesting to know whether the built in forwarder uses the servers in the correct order.

Hi thanks,

Sorry for the lack of response from me, i’ve been kind of busy (2 sons aged 0 and 3 need my attention ).
I’ll try as soon as I have some time and will post the results.