Dual audio issue

I have a model B and a model 2 with the same issue. Issue has been present since alpha but thought I’d bring it up since it has not been fixed in latest build. If i configure audio output to PI:HDMI and Analog i am unable to play any video encoded as dolby digital. When i set audio to HDMI only the files play fine.

You need to disable passthrough (passthrough though analogue is not possible).
On Isengard dual audio gets disabled automatically when passthrough is active.

a way around is to connect the audio cable in the TV audio-out instead of connecting in RPI. Keep the passthrough enabled.

Disabling the pass-through did the trick for me. I use the audio output on the PI for a bluetooth adapter for headphones when I don’t want to wake the house. My tv does not have an analog out so the second option will not work for me but it is a good suggestion nonetheless.
thanks for the tips.

@pcwii do you notice any lag between tv audio and bluetooth headphones audio?

I have not noticed anything significant. If i am wearing the headphones and turn up the tv i notice a small lag but not enough to cause me grief.


Wondering if there would be a way to keep passthrough all the time active and have the stereo output for the headphone the same time.

Use case is same as pcwii has, I have a BT transmitter (Avantree Priva II) connected to my PI and would like to listen to it using a BT headphone.
The reason for using the PI is that my receiver does not have an output I could connect the BT transmitter to (only option would be the headset connector, but then all speakers are muted). As all the stuff is connected with HDMI no audio is available at the TV headset jack. Zone 2 on my receiver can not play digital audio inputs, only a few inputs are available…